Ana içeriğe geç

Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

381 Soru Tümünü görüntüle

Coloured bars on screen on startup. Doesn't power external keyboard.

Good day everyone,

My relatives have this 27" imac they were using up until it randomly started displaying coloured bars on the screen. I have since been attempting to diagnose this (With a trusty ifixit kit and some PC knowledge), but nothing has availed and it remains this way. I tried plugging in a USB keyboard but it does not receive power (AKA the caps lock and all other functions don't work) yet plugging in my samsung SSD it powers just fine over the USB ports but it doesn't show data reading. Trying different combos such as unplugging, holding pwr button, plugging in whilst holding pwr button, letting go and turning on have led to Full tilt fan spin (I don't know what this actually does. does anyone know what it does?)., it reveals the same result.

Heck, I even went to the effort of taking it apart to inspect the graphics card but that unveiled absolutely...................nothing. That means that this imac was gonna be ewaste in council cleanup but i said no so i took it home and am now running a few tests on it. This imac is one w Mini DP and firewire which really sucks because I have a dell S2722QC which is HDMi and USB-C only so i can't really get it to work on this display, however i do plan to buy an adapter to see if it boots onto an external display. This yielded nothing but black screen on both a 4k dell and a TV

Hopefully you guys are able to figure this out as my research has shown no one else has had this issue. I am suspecting graphics card failure but it could be one of the connectors. Note: i took it apart after it was like this and put it back together to find it in the same state.

Update 18/4/22:

My imac 27" is EMC 2390 yet looks like the previous model with it's graphics heatsink. Which set of guides should i follow?

Block Image

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

There is a set of hidden onboard diagnostics LED's which you should look at to see what they tell you.

To locate them after pulling off the display look down in the far left edge of the logic board, there is a small piece of tape covering them,

Block Image

Block Image

LED 1 - Indicates that the trickle voltage from the power supply is detected by the main logic board. This LED will remain ON while the iMac is connected to the AC power. The LED will remain on even when the computer has been shut down or put to sleep. The LED will turn off only if the AC power is disconnected or the power supply is faulty.

LED 2 - Indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED 3 - Indicates that the computer and the video card are communicating. This LED will be ON when the computer is communicating properly with the video card. If LEDs 1 and 2 are ON and you heard the startup sound, but LED 3 is OFF, then the video card might be installed incorrectly or need replacement.

LED 4 - Indicates that the computer and the LCD display panel are communicating. This LED will be ON when the computer is turned on and video signal is being generated. If the LED is ON and there is no image on the LCD display panel, the LCD display panel or inverter might be installed incorrectly or need replacement.

Bu yanıt yardımcı oldu mu?

Puan 1

25 Yorum:

I hear no startup sound and when i forcibly turn it off it makes a very subtle pop sound followed by the fans turning off. I did open it up earlier today but it's 10pm so i don't really have time now but I'll try tomorrow morning and see if i can find the thing you said.

tarafından

@np_f1_2021 - A pop sound is telling me you have a power supply issue or a capacitor on the logic board has failed. You'll need to fully remove the logic board to inspect for a burn't component or two.

tarafından

Morning!. With regards to the "Pop sound", it's like the fans are running and the hard drive then it just isnt once its off.

tarafından

@danj I see three of the four LED's on when the computer is powered up what does this mean? When it's off i see one lit up

tarafından

Update: All the LED's come on when powered up meaning all those are working fine.

tarafından

20 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Nick P sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 1

Son 30 gün: 3

Her zaman: 123