Ana içeriğe geç

The March 2015 update of Apple's 13" MacBook Pro Retina Display, model A1502, features fifth-generation Intel Core i5 and i7 processors and introduces the Force Touch trackpad.

1098 Soru Tümünü görüntüle

Laptop turns on only on charger, infinite reboot

I bought this laptop used a year ago, and like a month ago I started facing issues. Trackpad sometimes was not clicking, keyboard sometimes did not respond - it was because of trackpad flex cable, and I used to fix it by disassembling my laptop and moving that flex cable a little. I bought a replacement, and was disassembling my laptop almost each day while I was waiting for the delivery. However, one day I was doing that same thing again and after I assembled my laptop again it refused to boot. Pressing on a power button did nothing, connecting MagSafe however turned my laptop on, only to reboot half-way through the loading bar. One more thing - as soon as I disconnect a MagSafe charger laptop shuts down instantly. I tried:

  • Replacing old trackpad flex cable with a new one, laptop behaves the same;
  • Booting without connected battery - MagSafe charger turns green then orange and laptop refuses to boot, pressing on a power button does nothing;
  • Booting without connected trackpad flex cable - same behavior;
  • Booting without anything connected to the motherboard - laptop still behaves the same.
  • Resetting NVRAM and SMC - it proves that keyboard works now (with a new trackpad flex cable), though laptop still behaves the same way;
  • Booting from a Linux live-USB - it tries to boot only to restart after some time, though that brief boot selector shows that after flex cable replacement keyboard and trackpad works without any issues;
  • Leaving laptop with unplugged battery for some time - laptop still behaves the same way;

I don’t have money for a new laptop right now (though I already started saving). Is it logic board fault? I fixed a lot of stuff before and never experienced something like that. Google said that this laptop should boot without connected battery, and mine certainly doesn’t want to do boot without one. However, IMO that still looks like a battery issue - my battery is pretty worn out (not bulging though), but it was working before that disassembly. Only reason why I haven’t bought a replacement battery yet is it’s price - I don’t want to throw away that much money in case replacing battery won’t solve my problem.

TLDR: laptop used to work, after another disassembly refuses to boot on power button, boots only when charger is connected, only to enter infinite reboot loop. Disconnecting charger results in immediate shutdown.

Sorry for bad (maybe) English, this is not my native language and I’m writing this while still thinking what to do now. I hope someone would be able to help me. Thanks in advance!

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

All your symptoms point to a bad battery! And given the age of your system its due! MacBook Pro 13" Retina (Early 2015) Battery and here's the guide MacBook Pro 13" Retina Display Early 2015 Battery Replacement

MacBook Pro 13" Retina (Early 2015) Battery Görseli

Ürün

MacBook Pro 13" Retina (Early 2015) Battery

$69.99

Bu yanıt yardımcı oldu mu?

Puan 2

3 Comments:

That was an issue indeed - battery replacement solved this problem, and now that I've already replaced trackpad flex cable this laptop works without any issues (not that I've done much testing - right now I'm calibrating new battery). And to clarify, as I wasn't able to find certain answer for that online - MacBook Pro Retina 13" (Early 2015) refuses to boot if no battery is connected, so it won't boot at all without properly working battery.

tarafından

@artemrisovach - It will but there's a trick! After you disconnect (remove the battery) you need to press the power button th fully discharge the logic board before you plug in the MagSafe charger (not the battery). Even still don't expect to do anything in this state! The SMC logic is in CPU Safe Mode which ramps up the fan and lowers the CPU's clocking.

tarafından

@danj I tried to do that this way - disconnected the battery, pressed power button for 10-15 seconds, connected MagSafe while still pressing power button and kept it pressed for another 10-15 seconds. Laptop still refused to boot. Maybe I'll try that later, but not right now - I don't want to mess around with components when everything is working. Anyway - thank you!

tarafından

Yorum Ekle

Yanıtını ekle

Artem Risovach sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 6

Her zaman: 63