DC Port Sparked, now only accepts cont. power,but not recog. Battery

Hi, I know these are a little outdated but this is my precious and first laptop, so there’s sentiment. What happened was that the DC port sparked with an aftermarket charger that I had got about a month prior. Then the computer would not turn on except that it was connected to the charger, but would not recognize the battery whatsoever. Even on the charger it would be running off of the CMOS (or whatever that little one is called) battery, so it seemed- because it would go super slow. I bought a new battery and tried it out to see if it was the battery.But it was not the battery or I skipped a step, either way, it still doesn’t recognize the battery, and looking back it did spark so I know now that there’s a disconnect somewhere in between the DC port and the battery. Can anybody help me pin point this with greater knowledge? I don’t see any blackening or disconnect from the 7 pins on the port and I don’t have enough knowledge on what goes in between— could the MB have fried somewhere?

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle