Ana içeriğe geç

iBook G4 powers on, but goes to blank blue screen after Apple icon


I've got an iBook 12" G4 1GHZ machine that chimes, goes into option mode fine, etc., but when I attempt to boot from the HD, CD, or external firewire drive, I get the Apple icon with progress wheel, and then it goes to a blank blue screen and nothing happens. I've gone so far as to put a known good hard drive with Tiger inside the machine, but still it stalls on the blank blue screen. I've run into many machines with this problem over time and would love to hear it's not simply a bad motherboard. I've tried PRAM/PMU resets, changing the DC-in, changing the RAM, and pretty much all the typical stuff.


Thanks for the tip. The memory isn't any unusual amount. The hard drives are definitely good. I think it's a logic board's just hard to give up on it, because it behaves perfectly in option mode, etc., and in the back of my mind it feels like there must be a way to fix it. I would say it's the hard drive's IDE cable, except that trying to boot from an external drive has exactly the same result.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 5
1 Yorum

I am a newb to these systems but i have an ibook G4 I tried all the suggested things also and on one i got to a screen that had a curved arrow on the left and another arrow pointing right and a drive picture or Icon showing a drive marked as m: in the middle with an X , seems I still got no where can someone educate me a little to what I saw ?


Yorum Ekle

5 Cevap

Filtre ölçütü:
Seçilen Çözüm

Have you tried booting in verbose mode (command-v)? Its possible you might get an indication of what hardware is failing if you can see the last kext loaded, or if it hangs.

If you have the Apple Hardware Test disc for this model, its definitely time to run it as well...

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle
En Yararlı Yanıt

If you've done all those things and if you know the hard drive works, it seems that the only thing it could be is a logic board error.

Although, how much RAM have you put in? Too much might not work, I believe 1GB is the iBook G4 limit.

You can double check the hard drive works by booting up and holding +S, then type fsck -fy

Sorry I can't be more help, I'm fairly certain it's a logic board issue.

UPDATE: Having read your update on your question I still think you have a logic board issue; but there is one thing I think you could try. Put Ubuntu on a CD and try booting from that, it might be that Mac OS X disagrees with the logic board but it still works. Here is a PowerPC version of it, use Disk Utility to Burn it to a CD and use option at startup to boot from it:

Click Here and download Mac (PowerPC) and IBM-PPC (POWER5) desktop CD

I hope that works

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Since you've already replaced the hard drive, did you try disconnecting the optical drive? I've had a bad optical drive keep a computer from booting properly.

Bu yanıt yardımcı oldu mu?

Puan 1


Hi! Yup, tried that. Actually I've discovered that an external monitor works. Which is very strange, because I've swapped the screen assembly/cables with a known working one. Is it possible that a "bad" GPU can work in such a way as to work externally but not internally? But then again because option mode DOES work on the laptop screen, and it goes blank when you go beyond that. It's as if the laptop is switching to external monitor mode after option mode is used.


Huh. It does sound like it's displaying on a ghost external, doesn't it? Zapping the PRAM usually fixes a confused display setup, but you've done that. With your external connected, can you go to Displays control panel and drag the menubar to the internal display?

Another question: have you tried resetting the NVRAM? (Boot into Open Firmware--command-option-o-f--then type "reset-nvram", return, then type "reset-all", after which the computer will reboot.)


Also, just out of curiosity, do you have an OS9 CD you could try booting to? Or OS9 on an external drive?


Yorum Ekle

I have seen this before in powermac g4's. In The end, a graphics card swap fixed it. the graphics chipset is integrated on these macs, so most likely, you may be stuck. have you tried resetting the PRAM (Boot holding Command-Option-P-R, until it chimes 3 times) this might solve the problem, you could also try re-seating the heatsinks on the CPU & GPU. though these computers are a pain to open (i have an ibook G3, and i had a very hard time upgrading the drives) Good luck, if you boot into verbose mode, it will most likely freeze after almost finishing, and the same with single user mode unfortionatly. (I could be wrong, it's been a while)

good luck,


Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

my moms MacBook does the same thing sometimes... you press and hold the power button when it stalls there and then when it turns of turn it back on

Bu yanıt yardımcı oldu mu?

Puan -1

1 Yorum:

This is isn't really an answer


Yorum Ekle

Yanıtını ekle

rdklinc sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 11

Son 30 gün: 19

Her zaman: 12,231