Ana içeriğe geç

Unibody MacBook Pro models with 13" displays produced from 2009-2012.

4626 Soru Tümünü görüntüle

How to remove dosdude patcher & install a supported OS

Hi, I am having some problems to remove dosdudes Catalina patcher from a 2009 & a 2011 Unibody. Can anyone point me to a working solution? I have no data to back up and I already have a bootable USB installer for High Sierra.

I also want to stick a budget SSD in it as it is painfully slow, the 2009 is a SATA II so is there a specific SSD out there 250gb or so that will run fine? Samsungs are recommended but they are a bit pricey for this old machine..... But 1st I need to wipe out this patcher EFI coz all I am seeing is a no entry sign if I try to install High Sierra.....

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Problem was eventually "Solved", It looked like the original patch of Catalina had 2 data partitions which isn't correct and we believe it was something to do with this that caused the mayhem. a fresh Catalina patch on a new SSD is now working fine, also the 2009 MBP actually cannot support High Sierra but El Capitain, my bad!. Massive thanks to @jadonlyon for his terrific input!

Bu yanıt yardımcı oldu mu?

Puan 2

8 Yorum:

@livfe - You're welcome! I do have something for you: https://www.dropbox.com/scl/fi/ehifsrux9...

This is a copy of OS X El Capitan from the App Store when it was still available. I have saved it through these years. Unzip the file, and you have the app. Now, when booting on the Mac, you will need to change the date to before December of 2017, or the installation packages will not verify during the installation. If you ever want to try it... there's the file to do so.

P.S. You'll see a button above my answer that says "Accept Answer." Click that while you're still on the page if you like.

Great job repairing!

tarafından

@jadonlyon Cool, I will download that over the next few days!

tarafından

@livfe - Awesome!

tarafından

@jadonlyon & @livfe - FYI - Apple has the older OS-X and macOS online here’s the link How to download and install macOS which also has the older OS-X

tarafından

@danj Yes, I got that link and have all the installers to make a multi-option installer External SSD, just finalizing the 'Updated' systems and trying to find a way to get a .pkg > .app of Ventura and Sonoma (I am using Monterey so apple won't let me install the .pkg to applications folder.... Problem turned out to be a damaged ROM in the 2009....It only no works with a patched system.

tarafından

3 tane daha yorum göster

Yorum Ekle

Hey there! This is my favorite thing to work with on a Mac. I would be happy to help.

First, reset the NVRAM and SMC.

Then, you will need to completely format the internal hard drive. When you stick the USB installer in the Mac, hold the Option key while starting. Here you will see the USB drive "Install macOS High Sierra" in startup manager. Click that, and click the arrow to boot from the USB drive.

Once loaded, head into Disk Utility. Here, you will need to click the "view" button, and "Show All Devices." This way, you can see the drives and partitions. Check your internal hard drive, click it, and then "erase." When formatting a drive, you need to use a GUID partition map (this will make a hidden EFI partition, and it will allow macOS to create more partitions during the installation [such as Recovery OS]). And, you need to format it in APFS. (A quick note here, if you are using a standard hard disk, use macOS Extended. The solid state drives do better with APFS.)

After formatting, Quit Disk Utility and click "Install macOS" (or Reinstall macOS). You can then follow the steps to reinstall macOS. Unlike dosdude1, the Mac will restart several times while installing. Eventually, you will see the Setup Manger, and you will setup your Mac as if it was new. You also won't need to Post-Install Root Patches (as macOS is natively supported).

As for the Solid State drive: I would recommend Kingston. I have a MacBook Late 2008, and it runs great with that solid state drive. Just note, you may have to activate TRIM support after installing macOS. Simple head into Terminal and type sudo trimforce enable. You will need to hit the Y key multiple times, and eventually the Mac will restart. Then, head into the Apple Menu  > About This Mac > System Report. Then, scroll down to SATA, and check TRIM. Here, it should say Yes if it is enabled correctly.

Okay, hopefully this gives you an idea on where to go. Feel free to drop something in the comments if something does not go as expected. Best of luck!

Bu yanıt yardımcı oldu mu?

Puan 1

65 Yorum:

OK I am going to try this, but the HDD does not want to erase or format, so can I just take out the battery and reset the SMC by pressing the power button for 10-20 seconds, then reset the PRAM on the next boot (with the freshly formatted Extended Journaled GUI mapped Micron M600 100GB SSD inside and then with the external media with HS installer start the completely fresh installation process? After a hopefully successful clean installation and the dosdude completely out of the system with the machines supported OS (High Sierra) I will then only use Open Core and try patching this to a 64bit Catalina OS, then give it to my niece for her coming birthday so she can use it for her studies.

tarafından

So I have formatted the SSD using my other Mac, reset SMC and PRAM successfully on the 2009 with the SSD inside, Installer USB connected..... CMD + Option +R / Option +R / CMD +R get a no entry / Option / CMD ..... All I get is either a white screen or the much loved no entry or question mark folder.. It seems there is no recovery mode or any way to get to terminal or disk utility. I do have a few other macs here so could I use one of them to "T" connect to the 2009 with an RJ-45? I don't have a USB to USB cable or a fire-wire thunderbolt.... or whatever I need to do that....the SATA cable is fine, I even swapped it out 2x with new spare ones I have here, furthermore this was the original SSD I had in it before that I wanted to swap out for a larger capacity one, so the system definitely recognized it before. .. which brings me back to my 1st post here.... Installing HS on this Micron SSD in another machine is maybe worth a try but thinking about that, it won't re-flash the EFI which is needed to boot am I correct? It is proper driving me nuts, can't wait to get this working natively and give it away LOL

tarafından

OK So I did the. above and installed HS on an external SSD and then put the SSD into the 2009 model, Reset the SMC & PRAM again, booted into option key.... up cane "Micron SSD (With HS installed)" & "10.3.6 Recovery" .... I boot into HS and get a no entry sign and the recovery and again a no entry sign.....CMD + N gets me a greyed out flashing globe, hitting return on the flashing globe gets me a no entry sign, but at least the SSD is recognized!.... tried every CMD + all keys 1 by 1, and Option + all keys 1 by 1....0. CTRL + Tab toggles between the SSD & Recovery....The same results when I connect the SSD externally....I put the SSD back inside and with the USB Installer connected reboot with the option key, all 3 drives show up but attempts to install HS are met with the no entry sign., I then put the SSD into the CD Bay, and guess what... I get exactly the same results as above. I am sure that if I put back the HDD patched drive all will boot up OK... but it is not working well at all.....yay

tarafından

So, sure enough after all that, I connect the patched HDD externally and it boots up fine as expected.... but I get the set up screen (Due to SMC & PRAM reset I presume)....so I give it exactly the same username PW etc....Once system has loaded I can see on the desktop the USB HS installer but cannot open on this (Patched Catalina) system.... So, I try a reboot and I gt the Internal Micron HS SSD (No Entry) HS 10.3.6. Recovery (No entry), Installer USB (No entry) & EFI Boot option that starts the dosdudes Patched Catalina ..... Once into Catalina, I go to disk utility & I can now see the Micron HS SSD... I open finder and select show hard drives and it appears on the desktop. I go to system preferences and start up disc & only the external Patched HDD appears. Software update has only Safari to be updated nothing more. I did a SMART check with disk drill on the Micron SSD and everything gets the OK no errors found. So I download the MacBook Pro EFI Firmware Update 1.7 for HS and tried to install it but the system won't allow. I really don't know what else to try at this point.... I have emailed DD to ask him to help....

UPDATE: I went again into system preferences and startup disk and low and behold the Micron SSD was there, so I selected it as the boot drive and restarted.... after restart there was that no entry sign but again checking the startup disk it give a message click to restart this mac in target mode.....

Installing a different SSD (ADATA & Samsung) into the primary bay with the installer USB connected, power on, option key, installer shows but get the no entry. ONLY the DD patched Catalina drive internally or externally successfully boots up.

tarafından

@livfe - I have to say, thank you for all of this information, helps me out a lot!

Have you read this article about macOS High Sierra? https://support.apple.com/kb/sp765?local...

The "No Entry" (I am assuming is the prohibitory sign) is essentially telling you that macOS is not supported on the particular Mac model.

https://support.apple.com/en-us/101666#:....

So, that means macOS Catalina will run with the patcher because the patcher can run on almost any Mac model. But, the native macOS will be much older than Catalina. So, here's what I would suggest:

tarafından

60 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

livfe sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 7

Son 30 gün: 54

Her zaman: 416