PowerBook G4 Aluminum laptops with 17" displays

211 Soru Tümünü görüntüle

Will not power up, checked adapter and battery

After servicing a wonky screen cable properly and not fiddling with what I shouldn't be (I have done this before) my PB suddenly will not power up. Yes, a different adapter was tried. Yes, the RAM cards are in properly. Yes, the PRAM is okay. All indicators seem to point to an inexplicable DC Input failure. Yes the logic board my have suffered some inexplicable urge to suddenly fail. But the adapter input does not light, tests were preformed with and without battery in, I even plugged a Flash Drive with an indicator light on it into the USB that is part of the DC Input board, and it didn't indicate power.

The adaptor plug will flash a rapid amber if there is slight pressure applied. Also there is a faint clicking noise in that region when it's plugged in.

Any thoughts?

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Try starting up from your system installation disk, "C" key with disk inserted. The clicking is usually a failed hard drive.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

Thanks for responding. Nothing is running to even permit that particular test. The faint click, emphasis on very very faint only occurs when power adapter is in. Noise is right there at the DC input board.

tarafından

First try resetting the SMC (power management unit): http://www.thexlab.com/faqs/resetpmchip....

To get you to the correct guides please give us the last three figures of your serial number.

tarafından

RJ3 I believe on the serial (will be more specific if you necessary) he Machine is a PB 1.67gh/512MB/100G 17"

To clarify some things I said in my original post... and before I forget, thanks for responding. I have not found some symptoms or at least anyone else with my set of symptoms.

First, I was under the hood to adjust a wonky screen cable. Did it before, no issues, nothing disturbed. Yesterday I was in there to do the same thing (I have serviced my mac in the past and am comfortable/know my limits) and upon reassembly there was nothing. No light from the adapter (tried another one I know works) although for two seconds I had a green ring, no noises, beeps etc. Simply dead.

The battery is fully charged.

I preformed the reset you mentioned numerous times. Nothing. PRAM seems to be fine.

T

Thanks again, used this site before, but not in the question capacity... plus I'm having a bit of a freak out over the predicament.

tarafından

Yorum Ekle

Yanıtını ekle

TLS sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 335