iPhone in recovery mode after battery changed

I asked this question a week ago and got no reply. Someone please help a brother out. I have an iPhone 4 that came in for a power issue. It would not restore, it kept throwing an error 2001 and would not power up unless plugged in. I put a new battery in and all was well. I restored the phone successfully and thought it was good to go. Shortly after I noticed that the battery was draining rather quickly. I let the battery die completely, then plugged it in to charge. The phone came back on in a boot loop where only the apple symbol was displayed. I then put the iPhone in dfu mode and tried restoring. No dice! Error 2001! The phone now only powers up when plugged in and has the connect to iTunes screen displayed. I've tried a combination of things since. Tiny umbrella exit recovery, boot rec ect... Still nothing. I even put another battery in it to see if that would do it but no such luck. Any ideas? Someone please give me some direction! Thanks

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle