Ana içeriğe geç

Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

586 Soru Tümünü görüntüle

Solved - A1278 Can't install OSX


I took my macbook to the Apple Store - they fixed it in abut 2days. It was ribbon cable connecting MB and HD.


My configuration is A1278 with Vertex 3, 8GB RAM (Crucial) and original HD in an optibay.

I can't re-install OSX, every time I try it takes about 20min to even get into installer, and after that disk doesn't get unmounted, so it can be formatted.

I can install Ubuntu and any other Linux distro.. I just don't know what to do.

It all started when I tried to teach my girlfriend some PHP basics and started Dreamweaver, after that Macbook just beach balled. After forced reboot it couldn't pass the boot (stop sign after a lot of loading).

I tried verbose boot and it reported that it can't mount root device.

I tried and formatted old-original HD that comes with a Macbook - same problem.

I'm sorry for my English, I know that it's not the best :).

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan -1

What's in the original hard drive bay?


Dan - all those Questions make this more of a comment than an answer...


Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Can you clarify your setup here: It sounds like you have swapped the devices around inside.

Did you take out the optical drive and then mount the HD in its bay then installed a SSD in the original HD bay? If that is correct I don't think you can boot up under the HD with OS-X in this config. The system BIOS is expecting an optical drive not a HD so the BIOS loader is loading the needed driver for the optical drive (not expecting a HD). You can still use the HD as a second drive though (not bootable).

Can you install OS-X and boot from the SSD? or can you use an external HD (FireWire) with OS-X on it to boot from?

You also talk about running Linux (Ubuntu) on the same system. If you had the HD in the correct bay I would have stated the boot volume is messed up, and you may not have a blessed OS-X volume as well to boot from. As your running a SSD here not a real HD in the HD bay I'm not sure if you can run a dual boot from it as the boot logic is different than a real HD.

Again, your in an area new to a lot of people as most don't get this complex in their setups.

I would scratch everything and leave the system with one running OS (OS-X). Then use VM-Ware to create a virtual machine to run Linux under inside of OS-X if that is something you want. It also simplifies the booting process.

FYI - Arstechnica just posted a nice write up on how SSD's work: Solid-state revolution: in-depth on how SSDs really work

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle
En Yararlı Yanıt

Sounds like a pooched HD. You should back up if possible, errase with 0s and reformat if possible. Sometimes a big crash will mangle the directory so bad it can't be repaired without 3rd party software and, sometimes, even they can't save it.

If this Answer is helpful please remember to return and mark it Accepted.

Bu yanıt yardımcı oldu mu?

Puan 1

1 Yorum:

Thanks - I have been "Security erasing" my SSD before i decided to just use Linux and setup becomes much quicker.

But it couldn't reformat my drive.

Will try to use your advice as best I can and I will report back with results.


Yorum Ekle

Yanıtını ekle

winsucker sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 4,941