Ana içeriğe geç

Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1145 Soru Tümünü görüntüle
Soru Kapandı

What do I need to do to get the power button working?

The power button on my iPhone was not working so i took it apart, and replaced the headphone jack assembly, got it all back together and it still doesnt work! When you push the button it doesnt go down at all? Does the little latch that is under the button just go towards the the back housing or did I put the button in incorrectly? Thanks

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

I'm quite sure that I put my replacement harness in correctly, but I can't get it to work either. The phone is constantly on and I can't get it to sleep by just tapping the sleep/power button...

I've tried complete reformat and restore, downgrading the OS etc but still no go...

I'm as lost as you. I can't think of anything else other than the motherboard that can be wrong, but I'm unsure what. A new motherboard is >$100 so that's not an option...

Bu yanıt yardımcı oldu mu?

Puan 0


Success!! I completely took it apart again. Removed the display assembly (but not separating this), mother board and sync connector. Cleaning everything by blowing clean, compressed air (from a aerosol can) in every nook and cranny and trying to get air in between the mother board and the RF sheilding from all directions, blowing everywhere on the back case and on and around the buttons (that where still in the case) and on all connectors (both on the mother board and on the flex cables). Then assembled everything again, making 100% sure that all the connectors where correctly seated. Turn it back on and loo and behold! Everything works like a charm!! I can turn it on and off, I can enter DFU mode and it doesn't reboot as soon as I unplug the sync cable!! Dang, I'm a happy camper now!! :D PS. Just in case this haden't worked, my next attemt would have been to spray/use some 'electronic cleaning solvent'.


Yorum Ekle

Hi, I had the same problem. Mounted and remounted everything with no succes until I ran out of battery and found out I could not plug in the charger cable... So I dismunted everything and found out that the Dock COnnector was wrongly mounted. It should be mounted above the two little metal brackets at the bottom of the iPhone. Re-mounted and works perfect now...

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 1,919