Ana içeriğe geç

The Canon EOS Rebel T2i is a continuation of Canon's entry-level line of DSLR cameras, the Rebel series. Also known as the EOS 550D and the EOS Kiss X4.

37 Soru Tümünü görüntüle

Why am I getting an Error 80?

I've had my Canon T2i for less than a year now. Recently, I've gotten an error 80 message. I've gone through all the "suggested repairs" without any luck. I can't take any photos, and when the camera does turn on and I attempt a photo, it will quickly turn off and give me the error message. HELP!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 4
1 Yorum

I am having this problem too


Yorum Ekle

3 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Melisa, that error is really only a very generic error "Err 80 Malfunctions related to the electric control or images have been detected."

-Turn the power switch to OFf then to ON; to turn on the power again.

-Remove and re-install the battery. (I believe it also has a RTC battery that needs to be checked)

-Use a Canon lens.

Clean the area where the lens meets the body with a pencil eraser. Hope this helps, good luck.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

I also encountered this error while on vacation and after off-loading images to a Chromebook and thence to Dropbox. Pulling the battery and replacing it reset the camera and fixed it for a short while; using a 70-300 Tamron lens exacerbated the problem, with frequent "Busy" signs in the viewfinder as it hunted for focus, and eventually the camera started to take a picture, flipped up the mirror, and froze, mirror-up!

After going through every camera-related trouble-shooting operation that I could think of, I recalled that I had once owned an Olympus Z-3030 camera (for 10 years it gave better pictures than any non-pro camera I could find, but used SmartMedia memory cards, which are unobtainable now, so is no more!). The problem with the SmartMedia cards was that if you didn't format them in the camera, and/or if you used them for certain types of file, they became unusable.

So I pulled out the (64 GB) card I was using, borrowed another (1 GB) from my wife, and the problem vanished. Err 80 was suddenly history. I found that I had left two or three .pdf files on the card after using it in the Chromebook. Removing these restored the camera operation!

Happy New Year (2014)!


Bu yanıt yardımcı oldu mu?

Puan 1

2 Yorum:

One thought: what kind of card are you using? For movies you'll need a type 10 card for it to be fast enough to accept the images being generated by the camera!


I had the same problem with my 60D and it ended up being a problem with the SD card. However, once I replaced the SD card, I needed to pull the battery and re-insert it before trying to power it on again. If I swapped out the SD card without taking the battery in/out, I still had the same error. So to recap:

1. Reformat the SD card in a computer

2. Pull the battery

3. Reinsert the battery

4. Reinsert the SD card

Now it's working perfectly.


Yorum Ekle

a Friend of mine camera was the same way. She would get an error messege and then the camera would immediately shut down. I took some time to take a look at the camera my self and found out that the Shutter Mechanism inside the camera has broken.

If you take of the Lens and look inside the camera as you turn it on the outter shutter would look like something was Bulging out of it and I knew something inside was unhinged or broke.

There after I took a paper clip and pryed oped the shutter to see that the inside part of the shutter release was broken some how.

that was the Cause of her Particular case of the Error 80 Message.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Melisa sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 5

Son 30 gün: 31

Her zaman: 27,453