Repair guides and support for external portable storage by Western Digital including the My Book series, My Passport and others.

151 Soru Tümünü görüntüle

Western Digital My Book Thunderbolt Duo will not mount.

My Thunderbolt drive Will not mount. Does not even appear in Disk Utility.

The power connects, and you can hear the drive functioning, however the light on the front no longer stays on and the drive does not connect to the computer at all.

When I took out the individual drives and connected them using an external usb device, each drive was fine.

They are RAID partitions, so I cannot recover the data without mounting them together.

So, I am thinking it is the thunderbolt ports. I tried both ports (there are two on the back, and tried a different cable. Nothing happens.

Thanks

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

GIVE TOOLS. FIX FOREVER.

GIVE TOOLS.

FIX FOREVER.

Spread the Fixmas cheer.

GIVE TOOLS. FIX FOREVER.

Spread the Fixmas cheer.

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Do you have access to a second mac? I would give that a try.

Depending on the model both thunderbolt ports are using the same controller logic so if one goes its possible the second has gone as well.

How do you have your equipment powered? Are you using a surge suppressor or a UPS and are pall of the devices sharing the same surge suppressor or UPS? Often I hear burnt ports due to power or lightning damage. I strongly recommend installing a whole house surge suppressor (in your fuse panel) and use a second one for the equipment or better yet use a UPS.

If you get power disruptions or lightning storms then a UPS is a must.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

Ashley Miller sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 1

Son 30 Gün: 10

Her zaman: 1,089