Model A1419 / Late 2013 / 3.2 & 3.4 GHz Core i5 or 3.5 GHz Core i7 Processor, ID iMac14,2

191 Soru Tümünü görüntüle

Why are fans speeding when screen disconnected?

I cracked the screen trying to remove it. It seemed to still work OK, so to prevent the crack spreading I used araldite to fix an aluminium strip right across the top of the screen and it ended up looking like an older, removable-glass iMac. Then the screen developed a broad grey vertical band top to bottom 4" wide when turned on. The warranty is void and a new screen is $1,000 Australian plus servicing costs.

So I disconnected the power and data connection strips to the screen and taped the loose connectors up with insulation tape. This was hopefully to prevent any more damage as the computer still worked OK using an external monitor.

However the fans are now going full speed.

Only the iMac screen is disconnected, so why is this?

Does the screen have a temperature sensor, same as the hard-drive? Does anyone know a fix?

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Yes, the display has a temp sensor which is why the fans are going at full tilt as it doesn't want the system to overheat.

This is such a new system I doubt anyone has done any repairs on it yet (still mostly covered under warranty). At this point I would say you'll need to find a new screen. Besides the needed alteration will likely cause other issues which could be worse in the long haul (shorting to systems life span or make it so you can't put a screen on later).

Why did you try removing the screen to start with?

Bu yanıt yardımcı oldu mu?

Puan 3
Yorum Ekle

Yanıtını ekle

John B sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 69