Repair guides for items used in conjunction with phones such as headsets, chargers, and cases.

82 Soru Tümünü görüntüle

Battery Bank USB Female port HARDLY has any connection with the USB

So last year I got this Battery Bank from Spire for my phone and it worked fine for 2-3 months then one day I started to notice I had to apply pressure with my USB under certain angle so the USB would get contact with it and start charging my phone.

I tried looking if there was any dust and cleared out what was there, tried 3 different USB cables but still no help.

So I'm turning to you guys hoping that you can point me into the right direction at least.

Thank you in advance!!!

Here are 2 close-ups images:

http://imgur.com/TUCmmO1

http://imgur.com/O4eY42Y

And this is how I have to apply pressure (almost really hard) to have ANY contact and start charging):

http://imgur.com/jqZcXPf

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

Yorumlar:

SPIRE SP-PB-4400-EU POWER BANK 4400

tarafından

Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

The unit has a 2 year warranty. I would see about getting it replaced as the connector solder joints inside are likely broken. From your pictures the contacts appear to be intact and have not been deformed so I don't see the external side of the connector as being the issue here.

These units are often welded so you can't open them. Looking at what I can see on your pictures and what I find on the web I don't see any means to open the unit (screws).

I supplied you the link above to their web site for the addresses and phone numbers - Good Luck!

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

Hreidmar sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 301