Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

863 Soru Tümünü görüntüle

Wacky Macey has issues

This bugger has more problems than me and my last girlfriend said I had a lot.

First off it would boot up but only with an external monitor. Zilch on the laptop screen even with light shining behind the screen.

After replacing the display it would boot up but didn't have any backlight on the new display, could now see items on screen though.

I found the backlight fuse to be bad so I replaced it.

Now when I connect the power supply (battery @ 90% charged and connected) the unit starts on its own however the sleep light gives one quick blink, fan kicks on and then it shuts off and repeats the process.

Never chimes (did before), display doesn't come on at all in fact the only thing that happens is the single flash and quick cycle of the fan.

Oh, the first couple of times the charge light was dim. It is now normal green and switches to amber.

Any ideas?

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1


Can you give us some background here. What happened to your system? Did you get it wet, drop or bang it? Does the case have any dents? if it got wet where and what. Are you using an Apple power adapter or someone else's?


Cable for the display became chaffed, open wire cut the signal to the display and another shorted back light fuse. Replaced it with a fully functional and complete display/lid.

Unit is undamaged in any way other than the former display cable.

Everything is OEM except for the new fuse which is a direct replacement. Have done about a dozen of them so far.

Unit had lost it display some time ago so I was using it with and external monitor. Finally decided to fix my own stuff for a change.

Didn't have a single problem with it as far as operating till now.


Yorum Ekle

Pro Tech Toolkit içeren veya $100,00tüm siparişlerde ücretsiz kargo!

Mağazamıza Göz Atın

Ever fixed something? That’s Genius.

Share your repair story with #ImAGenius

We Are All Geniuses

Share your repair story with #ImAGenius

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Have you tried resetting the PRAM? OS X Mavericks: Reset your computer’s PRAM

I would also try setting up a USB thumb drive as a bootable drive and see if the clean install on it allowed your system to run better. In any case you might want to test and repair your HD permissions and any disk errors.

Let us know how it goes.

Bu yanıt yardımcı oldu mu?

Puan 1


Sorry Dan but I must not be saying this right. The unit will not do anything other than power up for two seconds in which time the sleep light will flash once, the fan will start and then it repeats the loop. None of the basic procedures have any affect, Pram, smc, standing on head and spitting out nickels etc. OSX is Mountain Lion


I'd love to see that, standing on ones head and spitting out nickels ;-}


OK, so no boot at all. Do you have an external HD which has a bootable OS on it? If you do lets try this: with the external drive plugged in follow this Apple TN: Startup key combinations for Intel-based Macs Here we're going to try to use the startup manager to select your external HD. Can you get that far? If you can't, can you get into AHT?


Nada, the only change I get is if I do sms the unit sits there doing nothing like it should, otherwise it will only do the flash and quick fan spin and repeat. I'm going to try removing the fuse that I put in to see if that is causing the problem. I tried disconnecting the display without any changes.


Yorum Ekle

Yanıtını ekle

Dana sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 77