Ana içeriğe geç

Model A1237 or A1304 / 1.6, 1.8, 1.86, or 2.13 GHz Core 2 Duo processor

372 Soru Tümünü görüntüle

Battery displays X after replacing battery?

I just received a battery, for my Macbook Air 13" Mid 2009, that I purchased through ifixit. I installed the battery, and now the battery indicator shows an "X" in the center of it. I am being told that the battery is faulty. Does anyone know what the problem could be? This battery cost me $124, is supposed to be brand new, but does not appear to be charging.


I was able to resolve the issue. The male connector, on the new battery that I received, did not fit into the female end very first. The connection was very loose and kept coming apart. I tried it again, and this time carefully used a small screwdriver to push the battery connector into the fitting on the board. I had to apply a bit of force, but it finally snapped in and the connection was secure. The battery is now charging and displaying the charge lightning bolt. I've replaced these before, but never had such a poor connection fit before. Appears to be working well. Thanks to those who tried to help. Cheers!

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3


Wow! Thanks for posting your update. I had the same situation and your updated response helped solved my problem! Very important to have the both connector fully connected. Thanks!


@prudnew - Give your self credit here! Mark your question as answered (go to the grey options pulldown at the top of your text).

Happy it all worked out!


Yorum Ekle

Dizüstü Bilgisayar Bataryaları

An easy fix for a big power boost.

Hemen Alışveriş Yapın

Dizüstü Bilgisayar Bataryaları

An easy fix for a big power boost.

Hemen Alışveriş Yapın

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Hi there,

It might be a software issue, a problem that has been haunting Apple for a long time now.

What you can try (and make sure you follow the steps as explained) is this:

-Power down your macbook

-Remove the magsafe connector

-Remove the battery

-Hold your power button in for at least 5 sec

-Reconnect the magsafe connector

-Wait till the magsafe turns green

-Wait at least 5 sec

-Put the battery back in

-Start the macbook

Let me know if it helps or we can try other solutions.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Hi Kevin,

I've tried to follow your steps and it works, but only when I'm keeping unplugging and plugging the battery pack in the connector again. When I turn the Mac on the magsafe plug turns green and is not charging. Since the battery pack is new and empty the Mac automatically shuts off when I unplug it.

Do you still think it's due to a software issue or the I/O boards needs to be replaced?


Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

prudnew sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 1

Son 30 Gün: 10

Her zaman: 756