Ana içeriğe geç

Model M5884 / 400 or 500 MHz G4 processor

23 Soru Tümünü görüntüle

PowerBook Will Not Start! No Battery Charge?

Hi i am having trouble with my PowerBook G4 Titanium Mercury system.. It seems that it will not turn on and the battery wont even take a charge, when i plug it into the back it lights up Orange not Green like I have been reading.. PLEASE HELP!!!!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan -1
Yorum Ekle

4 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Green means the battery is fully charged. Orange is charging. Sometimes these machines will not start up with a fully drained battery, they need some charge before starting. Plug it in. Hit the start button and go take a shower. When you come back it should be booted up.

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

good answer +

tarafından

Yorum Ekle

No light will not come on. Power adapter works. I unpluged it for being away for 4 months. Upon return pluged it in. NOTHING HAPPENS

Any suggestions??

Allan

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Leave it plugged in for 30 minutes, then try a restart.

tarafından

Yorum Ekle

Same here kept my PB for longer then a month as now can't start, Done everything is suggested here. Kept is plug for more then a over night charging. Still didn't charge the battery or started with mains on.

Please Help.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Please start a new question so we can address your issue specifically.

tarafından

Can be have a link to your question if anyone replied to it because idk if that's the problem I have. Mine hasn't been turned on for two months and I got a laptop adaptor from amazon so I hope it charges :\

tarafından

Yorum Ekle

I have had this kind of problem too where my charger is fully OK and the battery works too. Even though the battery last for just 30 mins max. The recieving point of the charger does not accept taking in electricity to the G4 PB. I tried to open up the keyboard cover in order to clean the reciever. The charging process takes alot of warmth and makes the metal in the recieving part on the computer a bit dirty. In kinds of makes a layer of dirt/flame/electrisity-burn on and this layer is making it difficult for the elerctrisity to come through. I cleaned it up yesterday and the charger worked ok for a while. But the same thing happened again this morning and I tried to use a spray soap bottle and a toothpin to clean it again but it didnt work. Probably because of the soap and water still keeping it wet. You should wait until it get dried.

Update

But what other options is there to solve this problem?

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

carljrfc20 sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 3,265