Ana içeriğe geç

Model A1051 / 4 or 6 GB hard drive

84 Soru Tümünü görüntüle

Why doesn't my click wheel work after I changed the battery?

The new battery charged up fine and the display is fine, but nothing happens when I push the click wheel. When I reassembled after putting in the new battery, it did not seem as if the orange click wheel ribbon stuck back onto the logic board; I hoped the metal bracket would hold it down in the right way, but apparently not. Is this fixable? Thanks!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
Yorum Ekle

3 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Sounds like you did not properly seat the connector back into the board. I would take it apart once again and make sure you properly seat the click wheel connector in it.s socket before attempting to close. just hope you didn't damage the connector on either end when you closed it without properly seating it. Use this guide here

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

+ Ralph

tarafından

Yorum Ekle

Like Majesty said, you most likely did not seat the connector properly back in place. If it is seated properly, however, then you may have damaged the connector or ribbon cable when working on the unit.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

I would recommend looking for damage in the cable or a lose connection like others said, however, sometimes when reinstalling the board, if it scrapes to much against the metal shell, it can cause a chip to break or fall out. There’s one chip that, if broken, will make the click wheel cease to work however the rest of the ipod would work fine. and lastly, I’m surprised no one so far has recommended taking off the top bezel and making sure the lock switch is in the right position, as that could be the problem and would be a very simple fix.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

ekeeling sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 2

Son 30 gün: 12

Her zaman: 3,805