No sound from earpiece


I've got a problem with an iPhone 5C in that there is no sound from the earpiece on either phone calls or voice memos. I've tried the full screen assembly from another working phone and I've tried the logic board in another body complete with screen and the result was the same. The phone does not think that it's stuck in headphone mode as the volume control during a call or earpiece mode voice memo shows the regular 'volume' display.

I've put an oscilloscope on the test points associated with the earpiece speaker connection, TP65 & TP66 as shown on the 5C schematic, but no audio signal appeared, just some slight fixed frequency / volume noise.

The phone has no evidence of water or impact damage that I can see (although the screen may have been replaced).

I've tried to reflow the audio codec IC using hot air but I'm inexperienced with board level repairs on phones so I can't be certain that I've done this correctly.

Is there a common cause of this? Am I correct in thinking that it may be a connectivity issue with the codec chip?


Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle