Ana içeriğe geç

Model A1224 / Mid 2007 and Early 2008 / 2, 2.4, or 2.66 GHz Core 2 Duo processor

604 Soru Tümünü görüntüle

PSU, or rather the motherboard?

Dear all,

I encounter something I'd like to have your opinion for…

A morning, I found my mid 2007 iMac off after having let it on at night.

The power button didn't work neither, nothing happened.

I opened the machine, and played with the diagnostic LEDs.

What I happen is somewhat weird (I think). The first-left LED gets on on plugging the AC cord, After 3 or 4 seconds, all the LEDs flash and then… nothing, strictly nothing.

Do you guys think it could be the PSU, or rather the motherboard?

Thanks in advance!

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

MacBook Pil Tamir Setleri

Başlangıç $69.99

Buy Now

MacBook Pil Tamir Setleri

Başlangıç $69.99

Buy Now

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Sounds like a failed power supply to me. Although this model is notorious (a least to me) for failing GPUs. If you were having video problems before this occurred please tell us your machines history for a better diagnostic.

UPDATE

LED #1 Indicates that the trickle voltage from the PSU has been detected by the logic board. This LED will remain ON whenever the iMac is connected to working AC power. The LED will remain on even when the computer has been shut down or put to sleep. The LED will turn off only if the AC power source is disconnected or the PSU is faulty.

LED #2 Indicates that the main logic board has detected proper power from the PSU when the computer is turned on. This LED will be ON when the computer is turned on and the PSU is working OK.

LED #3 Indicates that the computer and the LCD are communicating. This LED will be ON when the computer is turned on and video signal is being generated. Front LED Indicates that the computer has power but no video signal (e.g., the computer is starting up or the display has entered Sleep mode, turning off the video signal). This LED will pulse when the entire system enters Energy Saver mode

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

Dear mayer,

Thanks for your quick answer.

Before this happened, I have only had one kind of somewhat weird behaviour, that occured some times for the last 2-3 years.

Sometimes, the display froze, except for the cursor that I was still able to move, with absolutely no effect on anything, frozen display, frozen clock etc… The only solution I had was a hard reboot and that's all.

This happened maybe twice a month.

Does it help you in any way?

Thanks in advance!

tarafından

Well that really muddies the water. The only thing I know to do is attack problems one at a time. If the power supply is known to be good then i would go for the video card. Get one from a dealer that accepts returns. The rate of failure on these video cards puts them in high demand, thus high dollar. The last two I fixed, I bought complete units off of eBay with things like a broken screen and bent case because they were cheaper than just buying the GPU. Be careful here because you can easily start spending more $ than the machine is worth. Find your best price then email me, I obviously have two know working ones. Probably part #614-0405. The number should be on a white sticker on the back of the supply.

tarafından

These parts should work for you 661-4665, 661-4478, 614-0405.

tarafından

Thanks a lot for your implication mayer!

For now I'm still not sure that the PSU isn't faulty. As I mentioned earlier, when plugging the power cord, the diagnostic LED 1 lights, and after 3-4 seconds all the LEDs suddenly flash and go off, with a small short circuit noise.

By following this test: iMac Intel 20" EMC 2210 Power Supply Output Voltage Test I get roughly the indicated voltages, which decrease to zero in a 2-3 min time, while leaving the power cord plugged.

I'm gonna do further investigation with the PSU before incriminate the GPU, and I'll let you know!

tarafından

Yorum Ekle

Yanıtını ekle

Vince1286 sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 84