Ana içeriğe geç

2, 2.26, 2.53, or 2.66 GHz Core 2 Duo processor

105 Soru Tümünü görüntüle

Mac Mini only runs 1.5 gigabit on SSD

I changed my internal hard drive with a Samsung Evo 250GB.

This drive runs at 6 gigabit but I understand my Mac Mini runs SATA at 3 gigabit.

But when I installed the SSD it only runs at 1.5 gigabit. Is there some incompatibility with the Nvidia SATA driver?

Does anyone know which drives work and run 3 gigabit?

Block Image

Update (09/10/2015)

Hi and lucky day! I returned the Samsung EVO 250GB and ordered a Crucial BX100 250GB from a local webshop. It said on their website that this drive is compatible for the 2009 Mac Mini. Of course all 6Gb drives "work" but the negotiating speed is the culprit.

When I installed the BX100 250GB I was disappointed because it also was set to 1.5Gb! I was on a chat with Crucial on their website and they suggested there must be something with "garbage collection" and to fix it I should take out the drive and let it stay connected to power only (no data connection) for at least 8 hours and the drive would fix itself. This sounded like a crazy solution but ok, I will try it. To my my amazement this really worked! Look at the enclosed pics. I get at least twice the speed I had on 1.5Gb. So my conclusion is that Crucial SSD drives work with the NVidia SATA controller in the 2009 Mac Mini. I guess this should work also with other Crucial SSDs.

Block Image

Block Image

So for my fix on this you would need an external power cable like an USB to SATA.

  • UPDATE ***

I upgraded from Mac OS X 10.9 to 10.10. I then noticed the Crucial SSD again had gone back again to 1.5Gb. Tried different things like resetting pram, upgraded Trim Enabler etc. No luck. So I thought I should try again the suggestion with putting the drive on power-only for some hours. That again did the trick! Amazing (but weird) solution. I am now back where I want with 3Gb speed.

Update (08/31/2015)

I checked the Crucial compaibility search and it says the BX100 should work. Will report back.

I also found this useful article on upgrading old Macs with SSD:

Update (02/29/2016)

The Mini is back to 1.5Gb :-( I have tried every trick except opening the Mini and doing the "let alone with power and no data" trick. I don't have time for that right now. So that did not last for long. I hate this issue. Sorry.

Update (10/02/2016)

I came by this discussion that suggested using the Kingston UV400 SSD drives since they have a Marvell controller and do not conflict with the nVidia SATA controller. Would love to hear if anyone has tested this.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 7
9 Yorum

What Nvidia SATA driver are you speaking about??


How are you testing? Please describe your process.


Sorry. I mean the Nvidia SATA controller. I attached an image. I have since searched for this issue and it seems that the Nvidia SATA controller does not negotiate well with all SSD drives so I have returned the Samsung EVO 250GB and ordered a Crucial BX100 250GB ( . From what I have read not all 6Gb/s drives understand to downgrade to 3Gb and then go down to 1.5Gb. I will report back the results.


sorry @ asle for back on 1,5......did you update to el capitan?

i stay @ yosemite with trim enabled in osX. Had always 3,0 Gbit with "sandisk ssd 128" and now "sandisk ssd plus 240".

Thought, i´ve found out that the´ve nearly the same controller silicon motion 2246...EN for bx, XT for sandisk.

so i will stay away from crucial......


It seems someone did the upgrade yes, not me. The BX should work I have read in this discussion. When I have time I will do the tricks laid out here, also the "power-only" cable and see if it works. Would be interesting to learn if Sandisk Plus behaves on Yosemite. Keep me updated (if you dare to try it!).


4 tane daha yorum göster

Yorum Ekle

7 Cevap

Filtre ölçütü:
Seçilen Çözüm

Thanks @Dan for your suggestions. Sorry i did not accept your answer since I solved it myself. From my experience the NVidia SATA controller is not easy to deal with. But that is what the 2009 Mac Mini has.

I have no problems with 2008 MacBookPs and 6Gb SSDs. They all autosense capable speed.

As it is hard nowadays to find any new 3Gb the conclusion here is that e.g. CRUCIAL SSDs work with the 2009 Mac Mini and NOT the Samsung EVO.

At least stay away from Sandforce driven SSDs. The trick with leaving the drive plugged into power-only for some hours is weird but works obviously!

The "problem" is Macs last too long. I doubt I would be plundering with a 2009 Dell laptop...

Bu yanıt yardımcı oldu mu?

Puan 3
Yorum Ekle
En Yararlı Yanıt

I think you'll find any SATA III (6.0 Gb/s) drive will fail here (fixed or auto). This systems SATA port speed is only SATA II (3.0 Gb/s).

Make sure your systems firmware is upto date as Apple did address some SATA port issues within the newer firmware level. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers

See if that works some of the newer versions of this system will work with the newer auto sense SSD's. If not you'll need to get a fixed SATA II (3.0 Gb/s) SSD which are becoming hard to find.

Bu yanıt yardımcı oldu mu?

Puan 5

5 Yorum:

Thanks but the firmware is up to date. The original Apple drive also runs at 1.5Gb/s even if the bus is 3Gb/s. What do you mean by "any SATA III will fail" ? I don't count a 6Gb drive running as 3Gb as a failure. Even if all newer drives are 6Gb they should autosense down to 3Gb. That is my experience on all SSD upgrades on 3Gb macs with the newer 6Gb drives.


This is a bit confusing :-( There are three SATA standards SATA I (1.5 Gb/s), SATA II (3.0 Gb/s) & SATA III (6.0 Gb/s). A SATA I system can only support a SATA I drive or a SATA II or SATA III drive which has been set to compatibility mode using a jumper (this also hold true with a SATA III drive in a SATA II system). Some newer drives have auto sense which allows them to match to the systems SATA ports speed. SATA III drives when they first came out also had this compatibility jumper, as the need for running in the older systems lessened the jumper was pulled. So you can find drive that are fixed at either SATA II or SATA III and now drives that auto sense. Sadly, not all systems can support the auto sense drives like this one.


No Dan, this is not confusing. If you read this post: you will see that the problem is the Nvidia SATA controller, not the drive. From my experience I have used almost any 6Gb current drive on any old MacBook system. All current 6 Gb drives (you can hardly find a 3Gb anymore) are autosensing. Seems there is something special going on with the Nvidia MCP79 (Mac Mini) not communicating with the drives controller (specially the Sandforce but also Samsung). The drive jumps back to its lowest possible speed which is 1.5Gb/s. Give me a few days and I hope to answer my own question with another SSD (Crucial). Btw. I have not seen jumpers on 2.5" SATA drives in many years.


OK, wasn't sure you followed things here on the SATA speeds. Correct the Nvidia controller has a problem running Auto sense drives. That was the point. You need a fixed speed drive and it can only be a SATA II drive. The drive you are pointed out here is a SATA III auto sense drive which won't work correctly. As you have noted it drops down to SATA I which is what it is programed to do when it can't detect the SATA speed. And yes SSD drives don't have jumpers any more as they are auto sense. Different SSD manufactures do auto sense differently. Some just drop to the compatibility mode (SATA I) or test and link up with the systems SATA ports speed (which is in some ways the better unit). But no all SATA ports (via the North Bridge or Platform Controller) the system has play nice. Some like the MacBook Pro's won't allow the better auto sense drive link up as their clocks are slightly off. So this is where the older fixed drives are needed and harder to find now.


As to the Apple drive: If you check its specs I think you'll find its a SATA I drive. At the time Apple couldn't contract for the better SATA II drives as the supply was limited.


Yorum Ekle

I just installed a 6 Gbps SATA III Sandisk SSD Plus in my late 2009 Mac Mini (running El Capitan) and was dismayed to find it operating at a negotiated link speed of 1.5 Gbps. I found a discussion thread from 2012 on the Sandisk Forums isolating the issue to a finicky NVidia MCP79 SATA chipset on Macs of that era and suggesting going with other drive manufacturers; I also found that Sandisk had acknowledged the problem and had released a firmware patch specifically for drives in Macs with the MCP79 chipset, albeit only for the Sandisk Extreme SSD. I figured I'd try the patch on the SSD Plus anyway (and return it to Amazon if it failed), so I burned the ISO to CD and tried to boot it off my external USB Panasonic DVD burner (the internal Superdrive has been dead for years). Unfortunately, the Linux system failed during bootup, so I rebooted to the SSD. To my surprise, I found the link operating at 3 Gbps.

I had no illusions that the failed firmware loader had miraculously updated the firmware, but I found it curious that the link would be at 3 Gbps after trying to boot from the CD. I ejected the CD and restarted the Mini, only to find it back at 1.5 Gbps. I put the CD back in and rebooted to the SSD, and the link was back at 3 Gbps. Even after several restarts it stayed at 3 Gbps, as long as the CD was in the drive. Then without the CD in the drive I tried running Startup Manager at boot (by holding down the Option key) and selecting the SSD, and the link was at 3 Gbps. I can now repeatably and reliably get the link to run at 1.5 Gbps or 3 Gbps, depending on how I boot the Mini to the SSD.

Based on my observables, I would isolate the finickyness of the NVidia MCP79 chipset to a timing issue at boot—if you allow the startup to occur normally, the link negotiation will fall back to 1.5 Gbps. If you instead interfere with the startup, say by having a CD in the drive or by running Startup Manager, the link will negotiate to 3 Gbps. I'd be curious to hear how other SSDs fare with this solution; I'd also be interested in whether the CD solution works on an internal Superdrive.

Bu yanıt yardımcı oldu mu?

Puan 5

18 Yorum:

Thanks @diablote for a really great post! You did some good investigations here. The buggy NVidia SATA chipset has a negotiating problem and your testing shows that is is a timing problem on startup. The chipset does not really care if the drive is 6 Gbps or 3 Gbps but is saying " can I negotiate with you - can you do 3 Gbps?" So on a delayed bootup the SATA chipset has time to negotiate with the disk and does not give up straight away.

The Sandisk firmware is forcing the drive from 6 Gbps to 3 Gbps which maybe the chipset understands then faster. I wonder if you tried my approach with leaving the SSD on power-only for some hours? Since the last upgrade to OS X 10.10 the SSD is still on 3 Gbps on every startup. I have not upgraded to OS X 10.11 but if I decide to do it I will post results.


I came across your USB power-only post and was about to try it when I found the Sandisk firmware addressing the issue (leading to the workaround I described). Given the trouble of opening the dang Mini and how seldom I restart it (it's an always-on file server), I probably won't get around to it soon. However, at some point I plan to replace the dead Superdrive with a SATA drive caddy, and I can test your method then. I then hope to add another SSD Plus and set it up as a RAID 0 with the other one.


Sure let us know if you test the RAID 0 setup. I fear newer SSD drives will be even more incompatible in the future to downgrade to 3 Gbps but then again how long will a Mac Mini 2009 last? Seems these macs last forever. I just fetched my old SE/30 from the loft and booted it up straight away (from 1989!) to play Prince of Persia. Wow, that is a fast mac, really.


I successfully swapped the dead internal Superdrive with a SATA 2.5" HDD caddy and installed a second Sandisk SSD Plus. I striped the two SSDs into a RAID 0 volume and successfully got El Capitan installed on it (a feat in itself thanks to Apple's disastrous gutting of Disk Utility). The link speed issue persisted (and still persists), and the power-only mode you recommended did not fix it. Further testing showed that the link speed is actually just random, and no interaction at startup influences the outcome. Out of 43 startups (21 restarts, 11 startups from off, and 10 startups from off with Startup Manager), I got 25 at 1.5 Gbps and 18 at 3 Gbps (58% and 42%, respectively). The highest number of startups at the same link speed was 4, and the minimum was 1. Interestingly, the second SATA channel always came up at 3 Gbps, though the speed of the volume went as the link speed of the first channel.


Hi @diablote, did you try the trick with an external CD to delay the startup? Would be interesting to see if a delayed negotiation would help.


13 tane daha yorum göster

Yorum Ekle


I have the same problem with my macs . Both runs MacOS 10.9.5 Mavericks.

I have SanDisk Plus 120Gb in Mac Mini (early 2009) and SanDisk z400s 128Gb in Mac Mini (late 2009).

In "early 2009" SanDisk works sometimes 3Gbit, sometimes it goes to 1,5Gbit. I cannot understand what affect at behavior like that. If I boot from external (over USB) HDD, I got 3Gbit/s every time! At this time no solution for this Mac.

In "late 2009" I had the same problem. Because I do not need DVD, I removed DVD from top bay and put Optibay (cheap from China) at that place. Then I installed SSD at lower bay and moved old HDD in Optibay. I clone HDD to SSD and made SSD as boot disk. There was no success - each time after I reboot I accidentally got 3Gbit/s or 1,5Gbit/s, for no reason. Again, if I boot from external HDD, I got 3Gbit/s! At last, I swapped HDD and SSD. I put HDD back in lower bay and SSD in Optibay. Well, in this configuration I got 3Gbit/s more times, bot not each time. Then I noticed a small switch in my Optibay. After I put the switch in another position, I got 3Gbit/s every time I boot or reboot. So this solves the problem.

Bu yanıt yardımcı oldu mu?

Puan 1

16 Yorum:

Sadly, the logic board has an issue which you can't over come with the SSD you are using. You need a fixed SATA II (3.0 Gb/s) SSD unit.

What is happening here is the SATA I/O speed sense logic on the SSD is getting confused. The sensory logic can't reliably tell what the systems SATA port speed is so it jumps down to the slower speed to make sure it will work (your SanDisk z400s 128GB drive). Your other SSD (SanDisk Plus 120Gb) is really not the right drive either for a slightly different reason. Unlike your z400s drive which has the ability to match up with any SATA I/O speed your Plus drive only has SATA III (6 Gb/s) or SATA I (1.5 Gb/s) compatibility mode. If you had a different system with a stable SATA II port the Plus SSD would never run at SATA II unlike your z400s.

Reference: Upgrading old Macs to SSD’s Which explains the problem.


OK what to do? See if SanDisk has a firmware update for your z400s SSD drive to over come the Mini's port problem so its able to run at SATA II correctly. Accept the fact the Plus SSD will only run in compatibility mode (SATA I) or look at upgrading it to a Fixed SATA II drive if you can find one or if you do manage to get the other system to work with the z400s SSD with updated firmware get a second z400s drive. If you can't get the z400s to work you'll need to get different drives or accept the fact you'll only get SATA I performance in this series of Mac Mini.


SanDisk SSD Plus specs

SanDisk z400s specs

Your systems specs:

Mac mini 2.26 GHz Core 2 Duo (Early 2009)

Mac mini 2.66 GHz Core 2 Duo (Late 2009)


Now I have results from Blackmagic Disk Speed Test:

Mac mini (Early 2009) with SanDisk SSD Plus - Read/Write=140/100 vs. 520/180 (from specs)


Mac mini (Late 2009) with SanDisk z400s - Read/Write=265/150 vs. 540/340 (from specs)

Really, I satisfied with the speed even for Mac mini (Early 2009) in comparison with usual HDD, but from this data I cannot understand, what is a real negotiation speed in SATA? If I understand correctly, the spec's speed presented for 6Gbit/s. So I conclude, my "Late 2009" runs 3Gbit/s. Is it correct?


If you look at the speed disk image I posted you get an idea of 3Gbit/s results which seems like you have now.


So here's the corrected numbers from Mega Byte to Mega bit:

140/100 : 1120/800 basically SATA I (1.5 Gb/s) throughput

265/150 : 2120/1200 basically SATA II (3.0 Gb/s) throughput on the low end.


11 tane daha yorum göster

Yorum Ekle

Hi @ All! Thank you for your great research!

I´ve got a mbp 13 mid 2009 with that .... nvidia chipset and controller. For Testing i put in a lowend sandisk ssd 128 last summer (which controller inside is nowhere to find - sandisk´s own?). In yosemite it showed 1,5 GBit firstly, after enabling trim for Non-apple ssds since yosemite 10105 it got it´s correct 3,0 Gbit fine running. Now i think about a 240gb version.

In my opinion sandisk made that firmware fix only for the first "etreme" because they had exactly that bad SF2281 controller built in, see

diablote´s tests with ultraII and plus from sandisk seem to be the best solution for me - the have marvell controllers both!?

On crucial side, someone tested a MX 200?

but exactly the 250 version is bad?

In conclusion i´m glad NOT to go for a samsung evo - like most experts on new hardware opting......;-)

I stay @ sandisk, hey just found that the ssd plus has exactly the same controller like the bx 100

sorry is in german....

Bu yanıt yardımcı oldu mu?

Puan 0

3 Yorum:

Did you review this link? How to change the Interface Speed of your HGST Hard Drive from SATA-III (6 Gigabit) to SATA-II (3 Gigabit). It goes into the issue a little bit deeper and they offer an optical drive carrier which supports the faster SATA III drives (HD or SSD).

Also don't get caught up in all of the benchmarks between the drives. Having a Porsche is greate if you can drive it on the Autobahn, doesn't help you drive in downtown Munich :-) Basically, the limits of the system remove most of the gains from a better performing SSD. Focus on what your needs are in the SSD's size and if it can be set to SATA II so it works correctly in your system with the carrier you have or get one that resolves the problem like this one in the link.


Yes i explored all the links, but mine is from 2009, here is 3,0 the maximum.....

It´s clear that all that 6,0 Benches don´t matter much for my case.

I´ve concentrated on the type of Nand memory --->MLC

and explored the Type of Controller --->Silicon Motion SM2246XT

Voila, it seems that these sucsessfull tested in above, the crucial bx100 and the sandisk Plus, they almost have the same Controller!

As an other result i learned that my fine working lowend sandisk ssd 128 could be replaced by a faster sandisk Plus. I look forward :-D

(from technical sight, there were also vram problems in this nvidia chipset generation around 2009, oven-bakening the logic board helped very well ;-)


In my case (mbp mid 09) after the sandisks i was testing a samsung evo 850 250gb(MZ-75E250) since june and it went fine under El Capitan. Now i've upgraded to a 500gb evo in december, works also fine, 3Gbit, trim enabled.

no poblem to be fixed, happy holidays @ all


Yorum Ekle

i have a crucial bx200 installed in my mini 2009, same chipset. It runs at 3.0 gb/s negotiation speed all the time no problem. I'm running El capitan. However, from what i read and noticed you have to allow the 'Active Garbage Collection' time and space to take care of the disk or it will throttle back to 1,5 gb/s. So don't stuff it and allow it Some idle time at the end of the day. It works for me. On a Mac, press the Options key while powering on to enter the Startup Manager screen. Leaving the Mac on that screen provides the SSD with power but keeps it in an idle state so Garbage Collection can function, just like the BIOS screen on a Windows laptop.

Bu yanıt yardımcı oldu mu?

Puan 0

2 Yorum:

Interesting if it works. Have to try that. So "some idle time" is 1 minute? 2 minutes or more? Will post back if it works!


I have almost given up getting this to work stable. It is just luck now if I get 3.0 gb/s. The only stable option I can conclude from all the posts is to attach the drive to the CD-ROM cable which seems to run stable at 3.0 gb/s. But then again will have to test. This is museum stuff anyway :-)


Yorum Ekle

Hi there,

I had the same problem and i think i have found a simple workaround for this problem.

Probably a little late, sorry about that …

I have tested it a number of times on my imac 9.1 and keep getting the same results. I booted my imac (press "opt" key), with a bootable Linux (mint 19) Live USB and found out that the link speed of my Samsung SSD was the full 3 gigabit.

Then I made the HFS + 1mb smaller with the linux disk program "Gparted" and then closed linux.

Then restart the Mac with macOS and voila the 3 gigabit is now available. (See screenshots)

The system will then function smoothly.

However, during disk check, macOS indicates a minor error on the disk. I suspect linux writes a value in the partition table which macOS interprets as an error.

I have not investigated this further yet.

When you fix the "error" in macOS in recovery mode, the link speed becomes 1.5 gigabites again.

I admit, the workaround is somewhat unorthodox but I didn't want to keep it from you.

Everything works fine so far.

More research may be needed to find out exactly what is going on.

Pls try free and let me know

Testsystem: Imac 9.1 with DosDude MacOS Mojave.

SSD Samsung 860 EVO 250 GB

Bu yanıt yardımcı oldu mu?

Puan 0

2 Yorum:

Your testing makes sense! As you have a auto sensing SSD (Samsung) what you are seeing it the SSD is dropping to 1.5 Gb/s at boot up and then as the systems port is running clean and is accessing a second partition it adjusts to the 3.0 Gb/s speed. The only risk here is over time the dirty cache writes within the Linux partition will build up and that could cause issues.

Still best to just get a fixed speed SATA II (3.0 Gb/s) SSD like OWC's Mercury Electra 3G



Thank you for your meaningful comment Dan.

I learned something again :-)


Yorum Ekle

Yanıtını ekle

asle sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 4

Son 30 gün: 35

Her zaman: 12,757