Ana içeriğe geç

My disc is unreadable for Gears of War 2 (downloaded)

No matter what I do the game Gearsof War 2 (which is installed on my xbox's hdd) sais that the disc is unreadable.

Ok I am going to label some examples:

One day I was playing Gears of War 2 with a friend. I got mad and raged and dashboarded in the middle of a game in which I was not host.

After that I loaded the game and persisted to keep playing with my friend. The game loads the Epic logo and then the Microsoft Splash but that's where the error happens.

1. I knew something really bad is happened so I deleted the game and system cache and re-downloaded the game I purchased from the marketplace.

2. It never worked so I tried signing out to see if the game would work. Signed out and the game still shows the error The disc is unreadable at the Microsoft Splash Screen.

3. I then called Xbox support. I insisted on that I do the 10 second power button thing. That didn't work. They said to delete everything from your hard drive. I did that and redownloaded my profile and game and that didn't work.

4. I told them that and they said ok what kind of console do you have? I told them I have the white console and they said no we don't repair those anymore we just do Elites and Xbox Ones.

5. Ok. So I try some tricks. I tried deleting my profiles and the game again and clearing system cache again and again and again. Still nothing. I then got my external HD WD PASSPORT and which I have my profiles and the Gears of War 2 game downloaded on. Ok I plug it in and snap off the original Xbox HDD. That didn't work either.

6. I tried glitching my way through one time and nothing. So then I kept trying and trying to glitch my way to load the game. Nothing. I ended up unplugging my power adapter over night and I plugged it back in the next day. It worked until I got into the menus then my console froze. So that sounds good I'll actually try that again tonight... ;)

7. I ended up going to Game stop and buying the Gears of War 2 disc. I insert the game in the tray and load her up. The Disc is still un-readable. I also downloaded the game from the disc. This did not work either.

8. I wake up the next day and keep trying. This time I try using the external WD Passport again but this time I also try doing something different. I am also using the Gears of War 2 disc Btw. Here's what I did: I load the game off the disc right? It loads and sais the disc is unreadable ok so what I did this time is clear my SYSTEM ITEMS and tried this and it actually worked. But it does freeze sometimes while playing. Also it only works with my WD Passport external HD (not the Xbox's HDD will not work attempting clearing system items).

Recap: So it all comes down to this. I've tried EVERYTHING from glitching to H-E-L-L in a hand basket, and the game just will not work downloaded on ANY HDD PERIOD. But disc will work only if you clear the system items everytime before use. Every other game I have works though. I admire that but the problem is if you guys are so tech-savvy then let's see you fix this notorious The disc is unreadable error... cough cough cough ...

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1


K so why are you asking you already answered it


No I didn't. Where does it show I answered anything? Wth u talkin about haha


oh ok sorry just misunderstood but have you tryed to buy a cleaning set for cd's and if you haunt try it


@denny009 does any other disk work in your xBox?

Rep: 1


But I'm not using a disc I'm using a hard drive. No matter what I do I can't play gears of war 2 offline or online...


3 tane daha yorum göster

Yorum Ekle

1 Cevap

Filtre ölçütü:

Leave the Xbox unplugged for about a week or so(I know it is difficult) and plug it back in this should work.

Sincerely - Cody R

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Denny Ross sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 1

Her zaman: 596