Ana içeriğe geç

Fix Your Stuff

Right to Repair

Parts & Tools

iPhone 6 in boot loop after screen replacement

So i have replaced a Iphone 6 Display (pre-assembled) and everything worked well (tested fron camera, homebutton and stuff).

Suddenly my friend told me, that somehow the device is not working and when he gave it to me (the same day) the iphone was stuck in a boot loop:

https://www.youtube.com/watch?v=wDas7WcM...

I tried to disconnect battery and also the reset with home button and power button, but still the same problem. Funny thing is, that I cant put it into DFU (it seems), because the device is restarting too fast. After that I tried to take another Display (from my working device) but the problem is the same.

I did not use the wrong screws (3 smallest bottom, biggest on the right, middle left)!

Please ifixit and community help me out :(

Thanks in advance.

Philip

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 10

Yorumlar:

Could be a chance the battery has gone bad.

tarafından

Hi @benjamen50 . Nope I just replaced the battery with a new.. same problem.

tarafından

hi I have exactly the same problem with my i phone 6 to,

please help

tarafından

@steve the full solution is posted in this thread but to sum it up you want to try a new front facing camera part. Did you have any luck with this?

tarafından

Hi I changed the camera over to the old one and the home button

And still the same problem.

After factory reset it is now working fine

tarafından

2 daha fazla yorum göster

Yorum Ekle

14 Cevap

Filtre ölçütü:
Seçilen Çözüm

The same thing happened to mine when i replaced my screen and put a new cable for my proximity sensor and front camera. I didnt know what to do, i tried so many things and it finally worked when i tried my old sensor and camera cable with my new screen. I got a new cable because my sensor wasnt working but turns out the new cable didnt work at all. It may not work for you but it did work for me and its worth a shot.

Bu yanıt yardımcı oldu mu?

Puan 12

Yorumlar:

Thanks for your input. I was really sweating cold.

tarafından

I fitted a new screen and when I turned it back on it was stuck in a reboot loop. Tried a restore using iTunes didn't work, unknown error 4013. Tried to restore again with the screen disconnected and it worked????????? Phone is working OK now but when it gets switched off a d turned back on it gets stuck in loop. Can't make any sense of it

tarafından

This is the exactly same thing I'm experiencing.

I can eventually get boot out of loop but haven't perfected how to.

Today tried something & seemed to actually work to get out of loop. I held the power button & home button (hold home button whole time)--> screen goes off let go of power button--> screen turns on plug in to charger real fast & then boots

But other way I usually got it to boot is by holding power/ home button then when turn off let go both & when see apple hold volume up.

theory is the screen mandates more power than original screen.

read/ tried loosen screws on display ribbon cover. Read Forum if the screws were placed in wrong spots that it could cause it not to boot.

When I try to restore my iPhone by putting it into recovery mode will try to restore and boots up & spinning wheel starts spinning for second & screen freezes & won't complete restore.

Let me know if you find a solution. Didn't buy official apple replacement display bought mine off Amazon so may be why causing boot loop.

tarafından

I figured out the problem. It was the front facing camera on the replacement screen! It would booted both with and without old camera attached to mother board. I installed the camera from old screen and boots perfectly now.

I suggest detaching camera and then proximity sensor and see if it boots if so either keep it disconnected or install old camera/ sensor from old screen.

Best of luck. 4013 I've learned is def a hardware issue you just gotta figure out what hardware if installed screen it is likely 1 of the 3 ribbons. Best of luck!

tarafından

I had the same issue, I bought this phone off Kijiji yesterday (buy and sell site $165 lol) so the guy gave me his old screen for parts. Just for laughs I tried the old screen because I couldn't get passed the connect to iTunes with the new screen attached. The old screen worked but because it was damaged I couldn't see anything. So then I tried the new screen by itself without attaching home button and sensor. LIFE! Screen works phone works AWESOME. So then I connected the home ribbon, home button works when rebooting phone no boot loop, but then I connected the proximity sensor. Phone works with it connected BUT when you turn the phone off and back on it boot loops at the apple logo also the front camera didn't work when it was on but everything else does. So not sure what's going on with this but it is strange.

tarafından

5 daha fazla yorum göster

Yorum Ekle

Exact same problem. Took the front camera out of broken screen. Replaced it in the new screen and boom... everything works perfectly!! It was a bad front facing cable. This is the last time I buy a full assembly from ifixit.

Bu yanıt yardımcı oldu mu?

Puan 3
Yorum Ekle

Had the same problem with my replacement digitizer from ifixit. I swapped my front camera, speaker and ambient light sensor and it fixed it. Works great now.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

Had the same problem too, replacing the "replacement camera, speaker, sensors" with the original ones from the broken screen fixed the boot loop issue for me too

tarafından

Yorum Ekle

Its acting like it has a battery connection issue or an issue with the battery gas gauge circuit.

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

@rbatzel I replaced the battery today, no change.

How to fix the issue with the battery gas gauge circuit. Where can I find this assembly/connection?

tarafından

I was thinking more something logic board side of the battery connection, not the battery itself. It is very easy to knock off the tiny components near the connection.

The battery gas gauge comes off the battery connection on the logic board and tells the processor the level of the battery. If the phone isn't reading from the gas gauge line, the phone will sometimes reboot.

tarafından

@rbatzel thanks again for replying! Can the battery gas gauge be broken, if I only replaced the display? I only did unplug the battery, to get the device out of the boot loop. If it is broken: How can someone fix that? Change the whole "battery to logicboard"-connector?

tarafından

Yorum Ekle

I am currently having this issue... The iPhone would show apple logo then immediately go to dfu mode then power off and repeat. I have now plugged the device into the wall using my iPads transformer and with that in place the device does not power off now but it stays stuck in dfu mode now. I try to put the device in restore mode with iTunes logo but I am getting no luck.

Here are some possible explanations:

1. The juice of charge doesn't surpass a certain % just stays at the level of being able to just power on

(I tried this with battery disconnected from MB and was getting same result: power on-dfu-off

2. Completely corrupted software.

Right now. I'm leaving the device in dfu mode with the iPad charger. Hopefully will be able to restore. Will let everyone know soon.

  • UPDATE:

SUCCESFULLY OUT OF BOOTLOOP! USE AN IPAD CHARGER!

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

You got lucky that time. For me I had to actually restore the firmware on a iPhone 6+.

tarafından

Yorum Ekle

Do you still have the old screen? If so try that again to make sure its not the screen. Also what i would do is unscrew the LCD ribbon plate and see if that changes anything. Its not a blue screen so luckily its not a issue with the mobo (I hope for you). If its still the same issue you can get to DFU mode by unplugging the Battery and holding the home button before plugging it back in.

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

Hey, thank you for your reply. I also tried to put in the old screen as well as another original screen from another device. Same behaviour. I might try the DFU mode, but the last time I tried (without unplugging the battery), it did not work, because device is always restarting too quick.

tarafından

it maybe motherboard damage from when you screwed in the screws for the LCD bracket. This is a very easy area to damage because they screw into the motherboard directly.

tarafından

I had the same issue, I bought this phone off Kijiji yesterday (buy and sell site $165 lol) so the guy gave me his old screen for parts. Just for laughs I tried the old screen because I couldn't get passed the connect to iTunes with the new screen attached. The old screen worked but because it was damaged I couldn't see anything. So then I tried the new screen by itself without attaching home button and sensor. LIFE! Screen works phone works AWESOME. So then I connected the home ribbon, home button works when rebooting phone no boot loop, but then I connected the proximity sensor. Phone works with it connected BUT when you turn the phone off and back on it boot loops at the apple logo also the front camera didn't work when it was on but everything else does. So not sure what's going on with this but it is strange.

tarafından

What’s this about the battery and home button for dfu mode never heard it I’ve been trying with home and power button

tarafından

Yorum Ekle

hello

do you have solution ??

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Did this get fixed! It happened to me and I really want my phone back

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Philip

I have same problem after changing my screen. Initially, phone would not power up after screen change, but unplugging the battery got it going again. Now it reboots just as you explained. One thing to add. I let it reboot until the battery died. When I pushed to power button it showed me a stable battery mode message indicating I needed to plug in phone. As soon as I plugged it in it went back into continuous boot mode.

Headed to repair store today.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

I had the same problem with a screen that came with front camera and proximity sensor. by replacing it with the original one (Including the ear piece) it worked.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

My issue was (or appeared to be) the sensor assembly.

I brought a COMPLETE replacement part for an iPhone 6G. Once replaced, Apple Boot Loop continued, DFU mode did not work, nor did a hard reset, just a continual boot loop.

I removed the stock sensor, camera, shield plate and home buttons from the complete part and replace them with the originals from the broken screen.

First boot worked - unsure if this could be a boot hardware initiation issue, maybe some of these component parts fail and cause the Apple loop.

Hope that helps,

Will

RocktScience.co.uk

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

I have been able to get my iPhone to boot by booting it in safe mode it does take a lot of patience tho. To do it hold the power button and then the home button until iPhone restarts then let go and hold volume up button (can take up to 5 minutes) until get to lock screen. Sometimes I have to restart and retry continuously but I eventually get it to boot. Not a complete fix but may be a bandaid until can find a better one.

tarafından

Yorum Ekle

I've seen this happen on a few iphone 6's in the past when one of the three connectors (lcd,digitizer, camera) are not plugged in all the way.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Nothing is work for me I tried everything everyone suggested on here but its still not working but i also added a new home button so that may be throwing it off but I tried rebooting it with it unplugged and it did the same thing but Im doing a screen replacement Iphone &.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Iphone 7 I mean.

tarafından

Yorum Ekle

i replaced my screen and my battery and ive tried everything on here but i still got bootloop i tried dfu and also tried updating my firmware and i dont have anything im still in bootloop when its in restore mode it stayes on but as soon as i try restoring it .. it goes back to bootloop

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Philip Phu Nguyen sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 16

Son 7 gün: 147

Son 30 gün: 561

Her zaman: 56,382