Cleaned water damage repair - Shuts down, Fan spinning fast. Theories


I have a macbook air 13 A1466 that suffered a little water spill and didn’t turn on or charge.(maglight lamp didn’t turn on )

Used your teardown guides and took everything apart. Found very minor corrosion in 3 places on logic board. Cleaned everything with isoproply alcohol and reassembled.


Still no light on charging cable but computer starts when plugged in (not if only on battery).

I get the bootup “dong” and get to the login screen. The Fan begins to quickly rev up and then spin extremely fast. Computer then shuts down. Usually shuts down in 15-60 seconds.

I tried to use "D" to get to diagnostics. Mac tells me to plug in power supply to being diagnostics (it is plugged in).

Since it actually powers up, I'm thinking it’s not a short, but overheating that shuts it down...

Not sure how to proceed next. Have some ideas…

1. Desassemble again and clean with Isoproply alcohol?

2. Open keyboard assembly and check for a short? (I took everything apart except trackpad and keyboard, and both appear functioning in login screen.)

3. Replace battery? It probably needs replacing, but not sure how it’s responsible for issues?

4. Clean CPU and reapply thermal paste. ( I didn’t remove the heatsink when cleaning everything…

I have a good feeling I can bring this computer back to life.


Update (05/16/2016)

Forgot to mentioned. I tried resetting PRAM and SMC. ..

Update (05/16/2016)

UPDATE: I replaced the battery and while maglite still didn't turn on, I was able to run diagnostic. There was no animation just black screen then got the following messages: (I also tried with a second power adapter)....

The Power adapter was not tested.

There may be an issue with the power adapter or it may not be connected to test the power adapter, reconnect it to the computer and try again.

Recerence Code: PPP007

There may be an issue with the system management controller (SMC)

Reference Code: PFM006

There may be an issue with the power management system.

Refernece Code: PPN001

So think this is good news in that if help narrow down the problem. I reset the SMC several times, and the PRAM.

Does anyone know what to do next?


Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
Yorum Ekle