Ana içeriğe geç

Works fine until a battery is connected, then shuts off

Hi All! I've got an A1138 PowerBook that works fine on AC power with no battery attached, but when I connect a known-good battery (I've tried several known-good batteries), the machine immediately shuts off. The AC adapter light, which glows bright green without the battery in, goes out completely and erratically flickers amber when you connect a battery. The machine won't power on with a battery in except occasionally, and quickly goes off again. Again, this all happens when a battery is connected, and without a battery, everything's fine. My first guess was the battery connector, but I replaced that with no change. Next up was the DC-in, and I tried 3 I had sitting around, although I think they all may be flaky to some degree, so I'm not confident I've properly ruled out the DC-in. I've got a good DC-in on the way, but I'm not sure that's the problem...this seems more like a short, or an electrical issue. Any ideas? I know it's not the RAM, AC adapter, resets, etc. Thanks!

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3

Yorumlar:

Got the replacement DC-in, and no luck. It behaves exactly like the other, which is perfectly, until you add a battery, and then the machine shuts off, and the AC light glows off and on amber.

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

OK, this is a shot in the dark. Disconnect the battery connector cable from the logic board and insert a battery to see if it's physical.

Bu yanıt yardımcı oldu mu?

Puan 4

Yorumlar:

Without the battery connector nothing happened. Good idea though!

tarafından

Sounds like a logic board to me. You guys have such interesting problems. + to both.

tarafından

Yorum Ekle

Yanıtını ekle

rdklinc sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 1

Son 30 Gün: 3

Her zaman: 2,110