Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Parçalar ve Aletler

Model A1237 or A1304 / 1.6, 1.8, 1.86, or 2.13 GHz Core 2 Duo processor

380 Soru Tümünü görüntüle

keyboard and trackpad not working

This was my first macbook air. I like it a lot, but I rarely use it. Well, I have a lot of computers at my house.

Since last year that I purchased the newer macbook air with the ssd, this was not doing anything much.Now this year with the ipad, even less.

However something strange happened to this macbook air when I took it out and try to sell it on ebay.


Let me explain. When I power on the laptop, right away, I hear the familiar apple boot sound. Then the laptop continue to boot. And finally

when it finish boot, I try to use it, the trackpad does not respond, so is the keyboard. I was thinking it may had crashed. But when I press

the power button. The shutting down message appear. So I know the computer did not crashed. I plug in a usb mouse and it worked. After

I turn it off and on a couple times. The keyboard and trackpad came back to life again. Then I put up the laptop. But the next day when

I tried it again. Samething happened. But eventually they work again.


Here is what I find out. If the trackpad or keyboard don't work, they don't work at the same time, never alone and since they are both usb,

they don't show up in system profiler. I tried press shift+control+option+power, the laptop turns off. So the keyboard maybe working.

I tried reinstall the system fresh, same thing. I will say one of 20 tried, the keyboard and trackpad will work. Maybe more, not too sure.

When it work, they appear in system profiler.

 any boady knows wich is the problem in my mac

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

4 Cevap

Filtre ölçütü:
Seçilen Çözüm

Well I've just had the same problem with a MBA late 2008.

The keyboard and trackpad wouldn't work at all - not even at boot time.

The USB port wasn't working either - it wouldn't boot from an external DVD drive.

I checked all the cables, looked for damage/spillage too - nothing.

Then I noticed that the late 2008 model has an nVidia 9400 chip in it. Could the USB ports/keyboard/trackpad be driven from the nVidia chip? I checked out the hardware description on the web and found that it does indeed drive the graphics as well as the USB, SATA, etc.

Knowing the nVidia chips around this era had issues with dry joints, I thought a reflow may be my last chance. So, out with the reflow station, let it cool and put it back together.

Powered on the MBA and the external DVD drive fires up, the keyboard and trackpad work too.

So, if you have the same problems, a reflow of the nVidia chip may fix it once you've tried the cables, etc first. I believe there are many services on the web that offer reflows on these chips.

Thought I'd share this with everyone!

Bu yanıt yardımcı oldu mu?

Puan 2
Yorum Ekle
En Yararlı Yanıt

From lack of use the connections may have built up some resistance on the connections for the keyboard and trackpad. Open up the computer and clean and remake the connections. If this doesn't work let us know and we will look further.

MacBook Air Models A1237 and A1304 Trackpad Control Cable Replacement

Bu yanıt yardımcı oldu mu?

Puan 2
Yorum Ekle

I'm having this exact same problem. I have replaced the trackpad control cable and the top case... I fear that it is a bad logic board..

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

I have the same issue! I purchased an A1237 MBA with a bad hinge and no sound, and have since replaced the screen and applied new thermal paste to the CPU. The keyboard and trackpad worked great, with both old and new displays, but one day, and since then , neither the keyboard, trackpad, or sleep sensor, will not work (it won't go into sleep when the lid is closed). I have replaced the trackpad control cable, but the issue persists! Something that also occurred at the same time was the system got insanely sluggish (10.6.8) and everything takes forever to load. I am able to use a USB mouse, and right from start-up the CPU is running at almost 100% with no running apps! Has anyone had this happen or know a fix?

PS Anyone have any good places to start for sound as well (no output from either jack or speaker, system profiler shows no audio devices)


Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

jaime ruiz sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 4

Son 30 gün: 13

Her zaman: 13,250