Ana içeriğe geç

Repair guides and support for Olympus digital cameras.

198 Soru Tümünü görüntüle

camera won't turn off while battery is insterted

My camera has decided that it will not turn off as long as I have the battery inserted. This started about 1.5 weeks ago (no dropping or damage happened), and still continues. I have to remove the batter to ensure that it turns off and not to drain the battery. This is the OM-D Mark 5 II model, just 14 months old. 2 months past warrenty which is killing me.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 5

Yorumlar:

I have had this issue as well, anyhow I had still warranty and it was repaired by Olympus service.

tarafından

Yorum Ekle

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hi,

Some suggestions to try:

1. Try a power reset -

Remove the battery from the camera

Turn on the camera.

Press and hold the shutter button for a minute or so. (This is to discharge the internal, non user removable back up battery. This battery maintains the settings in your camera when you remove the main battery).

Release the button and switch off the camera.

Re insert the battery and switch on the camera.

Try turning it off and see if it works correctly.

If it does you may have to reset the date and time settings etc., as these will all have defaulted to a factory default setting. Allow the backup battery at least 24 hours to recharge (from the main battery) before removing the main battery again.

2. If that didn't work, have you got the latest firmware installed in the camera? It may be that the firmware has become corrupted. Even if you have the latest firmware version installed try installing it again (I don't know if the camera will allow this or whether it only permits updates) and see if this resolves the problem.

Here is a link to the firmware for your camera.

http://www.olympusamerica.com/cpg_sectio...

Bu yanıt yardımcı oldu mu?

Puan 4

Yorumlar:

The power rest worked for me.

tarafından

It worked for me too, and I didn't even lose the date. Thanks

tarafından

My camera will not turn on without the battery inserted. Once I insert the battery then I can't get it to turn off. TG3

tarafından

This saved the day for me and worked perfectly. So far, it seems to be a one time occurrence.

tarafından

Worked! I love internet friends!

tarafından

3 tane daha yorum göster

Yorum Ekle

I had this happen to me, but none of the above worked. What did work was using a hairdryer on it. (cool setting)

I remembered I had been at a splash park a couple weeks prior and thought maybe some moisture had gotten in.

My fix:

I opened the side rubber flap and took off the PC flash cap.

5 minutes of blowing air (cool) around the switch and into the USB/HDMI ports did the trick.

A week later it did start to act up again, but another few minutes of hairdryer took care of it.

Me thinks that switch isn't as weatherproof as the rest of the camera.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

I second this. Exact same issue, and surprisingly the hairdryer treatment on the switch and ports area (maybe headphone socket allows air to reach power switch contacts ?) fixes it, but only for a short time, a couple of days.

I have the same problem but the camera is never near moisture. I do live on the coast but it is rarely humid.

tarafından

yup....hairdryer worked, camera was fine until I was caught out in a deluge...so much for it being weatherproof, bit sad really, was considering an upgrade to em1mk2 but now I'm not so sure !

tarafından

Yorum Ekle

Had this problem for about a month and I tried the suggestions here but did not work. Then I tried spraying some isopropyl alcohol into the dial and switch, flicked it back and forth, spray some more and flick around again. Then blow out as much alcohol as possible and leave for a while. Came back, cleaned with dry micro fibre cloth… and it was fixed!!

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

I've repeated the blow dryer only fix I mentioned above over the last few years. Well, that eventually stopped working for me. Was moments away from sending it to Olympus when I saw your alcohol fix. Fantastic! It worked. Saved me well over $300 in repair and shipping charges. Thanks!

tarafından

I also followed the previous steps...

Few drops of isopropanol a.k.a. isopropyl alcohol with a baby cotton bud to the switch did the magic finally. (You possibly find isopropanol from your home. It is normally used for wound or medical equipment desinfection.)

Greetings from rainy Lapland!

tarafından

Yorum Ekle

Yanıtını ekle

michelle sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 11

Son 7 gün: 53

Son 30 gün: 196

Her zaman: 14,402