Ana içeriğe geç

Apple iPhone 5s, 10 Eylül 2013 tarihinde duyuruldu. Bu cihazı tamir ederken daha önceki modellerde kullanılan aynı tornavida ve plastik açma araçları gereklidir. GSM/CDMA olarak, 16,32, 64 GB kapasiteli Gümüş, Altın ve Uzay Grisi renkli modelleri mevcuttur.

3904 Soru Tümünü görüntüle

Several problems with my iPhone 5S

Today I bought an iPhone 5s from someone who wasn't honest with me. Turns out the LCI indicators are pink, which means water damage.

She told me that the home button doens't work and that the phone shuts off at 40%.

The phone turns on and works 'perfectly' with a few flaws.

Problems:

- Home button clicks but doens't work. Touch ID works and I can get the control center to show up. I can also use the home button to get into DFU mode. Really weird..

Block Image

- When the phone is turned off and I plug the charger in, it goes to the Connect to iTunes screen.

- When phone is turned on and I plug the charger in, it will charge. But if I afterwards turn off the phone with the charger still in, the phone will turn off and go to the Connect to iTunes screen.

Block Image

Block Image

- If I restore the phone in recovery mode, it will restore it and ask me again to connect to iTunes to restore it. Sort of a loop. To stop the loop I plug the cable out once it restored. If I then turn on the phone, I get to the white 'Hello' screen and can normally install the phone.

Block Image

Block Image

Block Image

Block Image

- When I press the sleep/power button for a long time, the phone turn off, apple logo shows up, phone turns off. (don't know if this is really a problem or me being paranoid lol)

I hope someone very experienced can help me :) I love all input ! Long live iFixit !

Update (03/02/2017)

Can't get weirder than this.. So the original home button was clicking and Touch ID worked fine, and I could do hard resets, DFU restores with it, but it wouldn't do anything when you click on it after booting when you're on the 'home screen'.

Just installed another home button I found from anther 5S. This one seems to work fine, also when you're on the 'home screen'. A bit sad, because this means I got to say bye to Touch ID functionality. All other problems seem to be gone after replacing the home button. No more problem getting stuck in endless recovery mode loops.

I'm wondering, is there a way to save Touch ID functionality and what could cause the problem with the original one?

Could a dip in isopropyl alcohol do magic? I'm not giving up on the old button just yet ! Why on earth would problems like recovery mode loops get solved by replacing a home button.

Big thanks to you guys Giga and Stijn !!

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3

Yorumlar:

It could; maybe a little corrosion hit the connectors and it is still working but not making a good connection so the OS does not recognize it.

tarafından

I received the isopropyl alcohol today :)

Is it safe to dip the whole home button flex cable in it or should I just dip the connector of the home button in it?

https://www.dropbox.com/s/tp2mi5svh53u6t...

tarafından

Try to just dip the connector, be EXTREMLY careful with it as it tears very easily.

tarafından

Lol maybe stupid question but how long should I let it rest in the alcohol? Should I brush it while in the alcohol or afterwards?

tarafından

Yorum Ekle

iPhone X Fix Kits

Warranty up? No worries, we’ve got the fix.

Hemen Alışveriş Yapın

iPhone X Fix Kits

Warranty up? No worries, we’ve got the fix.

Hemen Alışveriş Yapın

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Try a new home button and battery first. Do the DFU restore then, since the indicators are pink wash the board with 90% isopropyl alcohol. Check for any corrosion and if there is brush it away gently with a new toothbrush. Reassemble and do another DFU restore. Good luck!

Bu yanıt yardımcı oldu mu?

Puan 5

Yorumlar:

Thanks for the quick answer. But I can't DFU restore since the home button doesn't work.

Should I first try a DFU restore or try replacing the home button and battery?

tarafından

Try replacing the home button and battery first.

tarafından

Turns out I can use the home button to do a DFU restore and hard reset. So it always works except when I'm on the OS. Frigging weird, really !

I received a battery today, so I'll try replacing that already.

Thanks for helping Gigabit :)

tarafından

Since a DFU restore didn't fix the problem, does this mean that the problem is hardware related? Sorry if I ask a lot of questions, but I'm really eager to learn about all this.

tarafından

If you did the DFU restore correctly, and it still does not fix it then yes it is a hardware problem. Was the battery issue solved after replacing it?

tarafından

8 daha fazla yorum göster

Yorum Ekle

You should better first check everything on the inside.

Does the board looks like it had water damage? Corrosion?

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

The LCI indicators on the back of the screen and just below the SIM tray are pink. For the rest I didn't really check for any water damage.

I will check online how I can differentiate a 'healthy' mobo from a water damaged one.

tarafından

You should not be so quickly with buying parts. Just an advise. I would rather first check everything and when you're sure about it, buy the parts.

tarafından

My experience haha :-)

tarafından

I'm planning on cleaning the connector end of the home button flex cable with some 99.99% isopropanol alcohol. Should I soak the connector end in the alcohol or use a fiber cloth or toothbrush and just brush?

All problems were fixed when I replaced the home button but I'm not giving up on the old one just yet :)

tarafından

Yorum Ekle

Yanıtını ekle

Didier Daniel sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 2

Son 30 Gün: 9

Her zaman: 645