Ana içeriğe geç

A game console released in North America by the Nintendo Company in 1985, called the Nintendo Entertainment System, model NES-001.

57 Soru Tümünü görüntüle

Nintendo acting weird when inserting controller.


I have a weird problem with a NES i bought some days ago.

The console is working, as in it starts and the game runs.

The problem i have is when inserting the controller.

I know my controllers work because i have tested both of them on my friends system and they work perfectly fine.

So when i insert the controllers to my system, as the game is running, inserting the controller into the port the games registers a "start"input and the my system stops registering any controller input at all. The controller cant communicate with the system being inserted.

So what have i don't to try to fix this. well we transferred my controller ports to my friends system and they work perfectly fine in his system.

so that made me think it was maybe a 72 pin connector problem. That is my game isn't having the right connection between the game and motherboard.

so we swapped the connector. NOPE, that didn't work either. So whats left them, well the motherboard.

I searched the whole mother board after soldering bridges and cleaned it all out the electronic cleaning solution. Still not working...

Anyone know what the cause is?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Ok So i found the problem, There are two types of controller ports it seems, one with the controller port attached to a small PCB with some diods soldered to it. This type apparently region locks some controllers, probably which causes the problem, the reason my ports worked on my friends console is because it was a first edition series imported from the states. So what i did was desoldering all the diods and resolder small jumper wires in their place, and voila! It worked flawlessly.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle
En Yararlı Yanıt

@john_t since both controllers are not working I'd start with the controller schematic and check the components that are shared like RA 1 (which is nothing but an array of multiple 10K resistors etc. Work your way through the schematic and see what you find.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 1

2 Yorum:

Yeah, i'll try that and see what i can find, never been good at reading those though. but lets see how far i can get. I bought a multi-meter just for this purpose, should i just look at continuity and resistance? also is there any measuring points and also some sort of "default values chart" that i should know about? Thanks for your answer. :)


@john_t your resistor and capacitor values are listed on the schematic. Test those accordingly. Your DA looks like a diode array. Use your meter to test the diodes in diode mode. There is really no crash course for testing a circuit board It will be a trial and error to learn to check components etc. Start with the basic as for identifying components like R=resistor C=capcitor D=Diode etc.


Yorum Ekle

Yanıtını ekle

John Tutumlu sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 1

Son 30 gün: 15

Her zaman: 783