Ana içeriğe geç

Released in 2013, Model number 19150 (Green) or 19167 (Pink)

6 Soru Tümünü görüntüle

Why won't my computer see this device?

I have plugged in My Own Leaptop to my computer and would like to reset the name. But it will not show as connected. The USB is fine, I just changed the name on a Violet Leapfrog doll with the same USB.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 8
1 Yorum

So close, I followed all these steps but the list of names doesnt appear and I still can’t change the name :-(


Yorum Ekle

6 Cevap

Filtre ölçütü:
Seçilen Çözüm


Has it worked before OK, when connecting it to a computer via USB?

Have you got the Leapfrog connect program installed in your computer?

This will install the drivers so that your My Own Leaptop will connect via USB

Update (05/26/2018)


Use a strong light and a magnifying glass to check the USB port to ensure that all the pins are there and that they are straight and parallel with each other.

Also check for any lint etc., which may be in the port enclosure. If there is use a vacuum cleaner to suck it out or if necessary use a wooden toothpick to gently dislodge anything trapped in there.

If the port seems OK perhaps it has become dislodged from the systemboard.

Here's a link to the ifixit Leapfrog My Own Leaptop Keyboard Buttons Replacement Guide which may help in gaining access to the systemboard so that it can be inspected.

Bu yanıt yardımcı oldu mu?

Puan 2

6 Yorum:

yes, it worked before when we set it up for the first kid. I reinstalled the LEapfrog app and just completed a re-set of another Leapfrog item (Violet) successfully. Same usb cord. It's almost like they no longer support the My Own Leaptop. It's 7 years old.


I just spoke to customer service. They discontinued support for this product in April 2018. So you missed it by one month. I guess we can toss it in the pile with our older iphones since we are basically being forced to buy a new product.

They did offer two free apps if we purchased another product.


Hey, the connecting software is no longer available on Does anyone have it?


Hi, I used this archived file and it still won't let me get onto my Tags or Readers. It does at least show that Connect is an option, but won't actually let me click on it and go anywhere. Can someone point me in the right direction? Thanks greatly!


1 tane daha yorum göster

Yorum Ekle
En Yararlı Yanıt

The item and software have been discontinued in 2018. I've been trying to do the same but finally found the answer on leapfrog website. That's a shame. It's a good toy and it's going to waste because I can't reset the personalization.

Bu yanıt yardımcı oldu mu?

Puan 5

3 Yorum:

I was curious if you tried finding a workaround. I was told it discontinued April 2018.


+1, Planned obsolescence !

a waste because you cannot customize anymore, shame on dev, I don't understand why is not possible to have the latest software able to make change with....


Well, given this, I am going to trash the Leaptop and NEVER buy another Leap Frog product anymore.


Yorum Ekle

Mine forced an update which then disables us from administering the myownleaptop. OK so this might happen but they should make the old version available to those who still want to use their purchase!

Bu yanıt yardımcı oldu mu?

Puan 2

10 Yorum:

I actually called customer service and it's like an iphone.... no longer supported. So they are forcing you to purchase a new product if you want to personalize any information. But yay!!! You can trash the product you have that works just fine and they will give you two free apps on the new product of your choice. I hate technology!


same business plan, planned obsolescence !


I have an iPhone as old as the Leaptop and they still work with no problem. This is way worse. Given also the fact that the app to personalize it was already done and the hardware doesn't need any update. They forced me to update the app then it stopped working with the Toys that we have. Well, bad move. I will not buy this company products anymore.


I downloaded the archive version and dodged the upgrade bullet by disconnecting the internet then connecting later, was able on the Computer (not leaptop) to change settings and it says sync'd...but on the leaptop nothing changes, it just keeps showing the arrows spinning.

Any trick I'm missing? Just trying to change the name mostly, giving it to a friend.

Thanks, Bryan


I'm having the same problem. I was given two used My Own Leaptops and want to update one with my daughter's name. I did the above (downloaded the archived version) and was able to update my computer with her information, but it will not sync to either Leaptop. Help! Thanks in advance.


5 tane daha yorum göster

Yorum Ekle

I found this on another iFixIT site. Maybe it will be helpful.


The old version of Connect for Leaptop is available from the Internet Archive. It took me several tries to download but once I got it installed it worked and all the audio files (for names, etc.) are still available (at the moment) on Leapfrog’s servers.

The original url was:

The version is

I had to DISABLE my internet connection when starting the program - otherwise it wants to (really, forces you to) “upgrade” connect and the new version doesn’t support the Leaptop. Then, I had to re-enable the internet to get the software to work once it was running.

Eric Lofgren - July 8

thank you, thank you, thank you!!!

Heather Manis - October 25

Bu yanıt yardımcı oldu mu?

Puan 2

2 Yorum:

thank you dan parker!!!!!


Thanks! Worked like a charm after I deleted the existing parent profile on the second hand Leaptop I got. The audio name files were gone, so it doesn't say my sons name, but I was able to type it in in the parent profile, so at least it displays his name. I'm ok with that.


Yorum Ekle

Hi Evan Ryan, I suppose you are mentioning about the USB cable is fine.

I would like to know more about the history of this devices,

If device has been dropped from a height?

Liquid was contacted with the devices?

Check on the device if the mini USB port if it has been damaged or loose.

you might need to open up to check if it is soldered in place .

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle


For French USERS, use this modified link (similar as above) to configure your leaptop :

To apply configuration, it’s MANDATORY to have or create an account in leapfrog website through the Connect application and declare it as NEW TOY. Otherwise your leaptop cant be configured , even if you have messages like it’s configured.

French : pour les utilisateurs français, utilisez ce lien de l’application française. Vous devez avoir ou vous créer un compte leapfrog afin de pouvoir appliquer la configuration, autrement le logiciel vous laisse croire qu’il configure votre jouet mais jamais la configuration n’est appliquée. il faut déclarer le jouent en tant que nouveau et le reconfiguer de A à Z.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Evan Ryan sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 8

Son 30 gün: 45

Her zaman: 23,474