Ana içeriğe geç

1.7 GHz dual-core Intel Processor (Turbo Boost up to 2.6 GHz) with 3 MB shared L3 cache

133 Soru Tümünü görüntüle

Only turns on with AC power

I have a 2012 MacBook Air 11”. It had some wine spilled on it a while ago. I took everything out and gently cleaned it with isopropyl alcohol. It worked just fine, but the mouse wouldn't move.

Today, I took out the trackpad and gave it an ultrasonic bath in isopropyl alcohol. Now it won't turn on, except for on AC power (and even then only sometimes).

Is this related to the trackpad, or is it something different?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

You’ll need a new trackpad as you ruined yours in the ultrasonic. These devices can’t be cleaned using a ultrasonic as the cleaning fluid (any) will seep into the plates damaging them.

Here’s the needed part: MacBook Air 11" (Mid 2011-Mid 2012) Trackpad

MacBook Air 11" (Mid 2011-Mid 2012) Trackpad Görseli

Ürün

MacBook Air 11" (Mid 2011-Mid 2012) Trackpad

$79.99

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

Thanks! Will this also solve the power issue?

tarafından

First replace the trackpad to see where things are then.

tarafından

Thanks! I replaced the trackpad and trackpad cable. This worked. Looks like something in the SMC reset circuit was messed up.

tarafından

Yorum Ekle

Yanıtını ekle

Buddy Guy sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 44