Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Parçalar ve Aletler

Model A1225 / Early 2009 / 2.66, 2.93, or 3.06 GHz Core 2 Duo processor

185 Soru Tümünü görüntüle

What can I do if my iMac boots with a question mark?

Block Image

Block Image

I purchased an older iMac a few weeks ago, because I couldn’t afford a MacBook Pro.

I don’t even know if the stats I listed are correct. This is what i do know:

8 GB memory, it’s 27” from corner to opposite corner and it’s a 2009,

In addition I finely found a great deal on eBay last week, and purchased a mid 2012 MacBook Pro.

After I got the MacBook Pro, I removed the HD, and used it as the drive to make a time machine full back up of my iMac.

The iMac I purchased was struggling with speed and I had my new (to me) MacBook Pro with an SSD and 16 GB of RAM, so I thought I would format the drive to free up some of the 220 of 250 GB I was using. I was only planning on using it to watch Sling, web surfing and listen to music. But, after I formatted, it wouldn’t load High Sierra on its own.

I downloaded High Sierra on my MacBook Pro, and used the command in terminal to install High Sierra on a USB thumb drive. It wouldn’t load from startup on the iMac, then i clicked startup disk, and clicked to install there - it did, and then when it rebooted, it will only show a question mark on the screen, I rebooted a few times,

I then I had a ridiculous idea, and decided to throw a copy of my Windows 10 CD in the drive, to try and get to a command prompt or anything other than a question mark - but it didn’t do anything , no surprise. hindsight is 20/20. I can’t eject the cd, and can’t get to terminal.


Update (11/08/2018)

I have been messing with this thing for 2 days straight now.. The only thing that I’ve been successful at was getting the CD out of the drive - Thanks Dan! Holding the mouse button worked.

Before I ramble on with the struggles I've had, I want to say this - When I purchased this iMac a few weeks ago, it had High Sierra already on it. Apple was as surprised as you all where when I called about a technical issue I was having a couple days in they wouldn't help me troubleshoot it, because of that reason.

Now for my trials and failures!

I have tried to install El Capitan, Mountain Lion, and High Sierra - on my 32GB USB and my 500GB 860 EVO SSD, with no success.

I’ve followed instructions on all, but the furthest I can get is a screen with a lock requiring a password.

I only have a PC Windows keyboard, but through all of my investigation I learned that the Windows key, is the command key on a Mac keyboard - but I have also tried many other options to boot from the Apple Site.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0


I think you've got your self stuck in an enigma problem!

Your iMac system's firmware doesn't support APFS which your SSD drive has! We know this is the case, as it did have High Sierra installed (and working?) During the OS install process the systems firmware needed to be updated but as Apple does not offer the required firmware for your system you're stuck!


Lets quickly review a few points here:

- Your iMac does not offer Internet Recovery so trying to access it won't work. If your drive was setup with the hidden recovery partition then you could access it. But as this is a fresh drive we don't know if its present or not after all of the alternations.

- The Lock Icon implies the system has a firmware password set which is why you can't get past it.

Unless you know the password you won't be able to get past it without resetting it using the grey recovery disk the system came with.

See if this works: Forgot a Mac Firmware Password? Don’t Panic, Here’s What To Do

Reference: About the screens your Mac displays as it starts up


I had a feeling you were going to answer first ! Dan the man has replied to all three of my questions first!

So my iMac is trash now'?


No, your iMac is not trash! But, you do need to clear the firmware password as outlined.


Dan the MAN! i have been able to reset the firmware password, and get to the recovery screen! now i just have to mess around with it, because it says the copy i downloaded can't be verified.. i will look on my time capsule and see if i still have a back up with el capitan.. but i doubt it.. i should be able to figure it out from here! thank you to everyone who tried to help! Dan is the man here! cheers


1 tane daha yorum göster

Yorum Ekle

LCD iPhone Ekran Tamir Kit'leri

Ömür Boyu Garantimiz kapsamındaki bütçe seçeneği.

Shop Kits

LCD iPhone Ekran Tamir Kit'leri

Onarım maliyetlerini düşürün, kaliteyi değil.

Shop Kits

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hold on here! You have a few different issues!

To start with your 2009 iMac can’t support APFS formatted drives (SSD or thumb drive) It also doesn’t support High Sierra on it either! The best you can do is El Capitan OS-X 10.11.x on this system

So you’ll need to leverage your MacBook Pro to get the needed OS installer from the Apps Store or get it from Apple Download site and then create the needed USB thumb drive installer. I think you’ll find this approach is easier How to make a bootable OS X 10.11 El Capitan installer drive

Then using it you should be able to run Disk Utility to reformat your drive and make sure it’s working. If it is then Go ahead and install El Capitan onto your iMac system.

To get the Windows CD out you’ll need to press the CD eject key top right eject key ⏏

Or, press the command key and the E key when you reboot your system.

Or, just hold the mouse button down when you reboot your system.

Bu yanıt yardımcı oldu mu?

Puan 3
Yorum Ekle

Sounds like either your HDD/SSHD/SSD has failed. That is typically what the flashing folder with the question mark means.

But, before we replace your existing SSD/SSHD/HDD I would suggest you boot into recovery mode (hold Command+R on startup, you need a wired keyboard made by Apple to do this too) and erase your SSD/SSHD/HDD with disk utility and format it into Mac OS Extended (Journaled) format. After erasing and reformatting your drive into Mac OS Extended (Journaled) try reinstalling HS and see if that works out for you.

If that is a no-go it’s time to replace your SSD/SSHD/HDD.

Plus, you want to say away from APFS when you upgrade to MJVE in the future.

iMac Intel 24" EMC 2267 Hard Drive Replacement

iMac Intel 20" and 24" (Mid 2007-Early 2009) SSD Upgrade Bundle

iMac Intel 20" and 24" (Mid 2007-Early 2009) SSD Upgrade Bundle Görseli


iMac Intel 20" and 24" (Mid 2007-Early 2009) SSD Upgrade Bundle


Bu yanıt yardımcı oldu mu?

Puan 0


@ajcooke01 - While he may need a new drive, lets make sure first!


Yorum Ekle

You should be able to get to terminal if you load up the install disk and it should boot to the "recovery mode" menu. From there you can access terminal. But I'm also pretty certain that high sierra isn't supported on this model of iMac. I know there are methods out there to get newer OS's to run on non supported machines, but that maybe the cause of your issue with the flashing folder.

Bu yanıt yardımcı oldu mu?

Puan 0


The older iMac's don't offer internet recovery services and as the HD is questionable the hidden recovery partition may not be present depending on the OS version and if the partition was created or not. And the drive may be bad so it won't be accessible then.


Yorum Ekle

Yanıtını ekle

justin sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 9

Son 30 gün: 45

Her zaman: 852