Ana içeriğe geç

HD is not showing up after DC-in install. Tiger DVD works.

This is related to the power adapter breaking off int the DC in port. The toothpick thing didn't work for me, but I did the step by step repair, replaced the part with one from iFixit. New adapter charges the battery just fine, but now my hard drive is acting weird. Booted up once in 20 tries. Got ? folder other times. Tiger install DVD using System Profiler sees something on the ATA sometimes, but no drive size or anything. Disk Utility doesn't show the hard drive to erase or repair. Any ideas what I messed up?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1

Yorumlar:

PS Tried zapping PRAM and starting in safe mode. COptionPR did nothing. Holding shift key down gave me Kernel panic info on screen end with"we're just hanging here"

tarafından

Yorum Ekle

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

First thing I always recommend is checking the cables. Make sure there are no loose connections. After that it could be a damaged hard drive cable or hard drive.

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

+ beat me. But very good advice.

tarafından

How do I check the cable? Top or bottom of the computer? Do I need to take the whole thing apart like replacing the HD or is there an easier way?

tarafından

Yorum Ekle
En Yararlı Yanıt

The 1.33 12" iBook G4 (like the 1.42 14") doesn't have a hard drive cable. It's only a male bracket that clips in a female socket fixed to the logic board. You need to apply a little force (with the flat side of a spudger) when inserting the HD bracket in the logic board socket and make sure to reinstall the grey plastic stopper that will keep a secure connection. Double check your HD installation.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

Thanks for all the help so far!

Update: I left off the plastic bottom off the laptop to try and boot from the Tiger Disk, but the heat shield was on. I found a post where you took out the battery and held down the power button for 5 seconds and then put the battery back in and retried it, so I tried that and it booted from the hard drive 12 or so times in a row. I thought it was fixed so I put the laptop back together and now it's back to the flashing folder and ? mark. I'll try checking the hard drive seating this weekend, but could it have anything to do with taking out the battery to put the bottom plastic case back on?

tarafından

Yorum Ekle

THanks for all the help! It did turn out to be a loose connection. I didn't have to open the top of the computer. It was on the part of the board by the hard drive, but on the bottom of the laptop that I had open for the DC in adapter. I'm attaching an image in case anyone else has the same problem.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

Your iBook G4 is not the 12" 1.33Ghz model. Could be the 14" 1.33 model. Please change your model identification in the thread title.

tarafından

Yorum Ekle

Yanıtını ekle

bookgrrl sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 622