Skip to main content

A1151 MacBook Pro 17" will not power up

I have a 17" MBP (a1151) that I got in 2006. I was on the internet (a message board) when the screen suddenly went black. I assumed it went into sleep mode but when I went to wake it up, nothing happened. Then I thought that maybe it just turned off suddenly (it's done that a few times in the past, usually when it would run hotter than normal while watching videos). So I push the power button and nothing happened. The battery was charged and and the green light on the power adapter was lit. I took it to Apple and they assumed the problem was the logic board but couldn't tell for sure since it would not turn on.

I removed the harddrive from the computer and put it in an enclosure to check the data (it was ok). I've since noticed a weird electrical sound (hum and clicking) coming from the left side of the computer (near the i/o board). I plugged my now-external harddrive via usb to that side of the computer (mag safe side) and the light on the external blinks when it is usually steady. When it is plugged into the right side of the computer via 800 firewire, the light is steady like normal. The computer will not turn on and I don't get the electrical sounds when it is only the battery plugged in (i get no sign of life with battery alone).

What seems to be the problem? Could it still be the logic board, the IO board or both? Assistance is greatly appreciated!

I also forgot to add that I have an ATI graphics card (ATI Radeon X1600). And the computer is Core Duo with a 2.16ghz processor.

Answered! View the answer I have this problem too

Is this a good question?

Score 1


Apple MacBook Pro "Core Duo" 2.16 17" Specs

Identifiers: MacBook Pro 17-Inch - MA092LL/A - MacBookPro1,2 - A1151 - N/A


Thanks! This seems to have worked. The computer was slow to start up (grey screen for 45 sec- 1 minute) but I eventually got a folder with the question mark on it. I put the harddrive back in and started it up again and again it was a little slow to start but I eventually got the apple logo then the log in screen a little time after that and everything seems relatively normal. I shut it down which was somewhat slower than normal to shut down but no weird errors or pop ups or anything.

I should also note that I did the hold-the-power-button for x amount of time but I must have done it wrong because it didn't work when I tried it lol. Is there anything else I should do or take note of? or does the problem seem to be solved?


But it did work!


Add a comment

1 Cevap

Chosen Solution

Try removing the battery and the AC adapter. Hold down the power on button for 10 seconds, then attach the AC and try to start, Note any sounds or lights or blinking lights and number of times they blink and let us know,

Was this answer helpful?

Score 5


Thanks for your help! I posted my comment under my question instead of your answer. Sorry! My observations are above.


Yep it worked.


Add a comment

Add your answer

Christina will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 3,154