Ana içeriğe geç

Complete repair manual for the PSP Go, including battery upgrade and display repair instructions.

89 Soru Tümünü görüntüle

Loss of audio Output From Units speakers.

Hi,

I have my psp go doing an odd thing.

It powers on fine and all functions are correct - save one. Audio.

Initially i susected that the device was assuming thati had headphones in - but when headphones are inserted the volume changes ion screen to the volume i had set last for headphones and audio is outputted through the headphones.

I then suspected that there may be dirt in the dock and thourghly cleaned the dock. Still no sound from speakers.

I then stripped PSP down as per your guides and looked at the speakers themselves - visually nothing "seems" wrong.

What areas should i be focussing on to rectify this fault?

Is it possible the speakers have blown after a heavy bout of dance/trance bass?

If so where can i obtain replacement parts?

Thanks in advance

Coxy

-EDIT-

Reading other psp go problems i found this fuse diagram.

http://www.mr-vizitkin.ru/images/stories...

I dont speak/read russian and dont know if these fuses are relevant.

Anyone care to share a translation?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
Yorum Ekle

5 Cevap

Filtre ölçütü:
Seçilen Çözüm

SOLVED

It is a piddly little fuse on the right side of the motherboard as you remove rear case.

It is marked with the letter L.

My fix is more of a bodge tbh.

I desoldered the fuse and used a bit of thin wire to make the circuit.

to make the fix permanent i need a new fuse lol.

Anyways hope this helps someone out in the future

Bu yanıt yardımcı oldu mu?

Puan 3

4 Yorum:

Great job, now all you have left to do is to accept your own answer. That way we will know that this works. Again, great job.

tarafından

Fuses blow to protect the rest of the system. By bypassing it you risk serious damage

tarafından

Here's what mine looks like (I desoldered those three little fuses):

https://i.imgur.com/SF8DQyg.jpg

When I get some thin wire soldered over the contacts to make the circuit, the PSP stops booting up. I take it off and it goes back to working (yet with no sound).

This is literally my first time using a solvering iron, so I'm wondering: is it possible that my board has gotten so messed up to the point that I'll no longer be able remake the circuit? Or am I just not soldering the contacts together correctly, and therefore should keep trying?

tarafından

I worked for me, thank you so much

tarafından

Yorum Ekle

I had the similar problem and by repairing the fuse problem solved.

Thanks Coxy.

Bu yanıt yardımcı oldu mu?

Puan 1

1 Yorum:

How exactly did you repair the fuse?

tarafından

Yorum Ekle

Im having the same problem here. No sounds through speakers. Earphones works perfectly.

I didnt silde the fuse of but I tried to connect 2 sides of a fuse with a wire but when they were connected the psp didn't boot up. when I remove the wire everything works again but still no sounds

is there anyway I can check if its really a fuse problem or not ? I'm just a noob so please help xD

I know this is an old topic but please help me !

Thank in advance :)

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

Same thing is happening to me :\

tarafından

Yorum Ekle

i replaced the fuse. now my start/select button don't work. You think related ?

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

What did you replace the fuse with?

tarafından

Yorum Ekle

^ you might have not have done it correctly.

Make sure you didn't leave any residue around the components. It can cause faulty things to happen.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Coxy sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 19

Son 30 gün: 153

Her zaman: 14,193