Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Mağaza

2.2 GHz (Turbo Boost up to 3.4 GHz) or 2.5 GHz (Turbo Boost up to 3.7 GHz) quad-core Intel Core i7 processor with 6MB shared L3 cache.

385 Soru Tümünü görüntüle

MacBookPro only boots when an external screen is connected

My friends MacBook Pro 15" 2014 shows some pretty weird behavior.

When booting up the process suddenly stops and and a black bar appears on the upper part of the screen. Then nothing happens anymore.

I tried to find out if it was a graphics problem and connected it to a screen over the Thunderbolt port. It booted up normally and i can even disconnect the screen and work normally. It even works when i only have the VGA-Thunderbolt adapter connected without the screen. (For DVI and HDMI the cable/adapter isn’t enough, there needs to be a screen attached, guess that’s a digital/analog thing)

He had NVIDIA CUDA installed and i removed all that because apparently that isn't supported in Mojave anyway. This didn't change anything though.

Does anyone know what might be going on here?

Thanks!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Carefully examine the display for any impact anomalies. It can even be the size of a pinprick.

Does it look kind of like this?

Block Image

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

No nothing like this. It's a straight line about 2cm wide from left to right and it only appears after it booted about 2/3. The fact that it works when i plug in the VGA adapter makes me think it's not an issue with screen itself.

tarafından

Please post a photo of what you are seeing as this is a very unusual problem.

tarafından

Yorum Ekle

To be on the safe side first do a PRAM reset and an SMC reset. If this doesn’t work are you able to boot into network recovery on the internal display? This will rule out a software issue.

See this guide on booting into network recovery: https://support.apple.com/en-gb/HT204904

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Thanks. I forgot to mention, did both of that and tried to boot from an external drive. From the external drive it's not a black bar but a thin fuzzy line which looks a lot like graphic errors.

tarafından

In that case try running Hardware Diagnostics: https://support.apple.com/en-gb/HT202731 plug in the external monitor if you can't see anything in the diagnostics.

tarafından

I just did a safe boot and that booted normally. I thought i had tried that already...

So could it still be some remnants of the CUDA stuff?

Hardware Diagnostics didn't find anything.

tarafından

it could be, Maybe do a reinstall just to be sure its gone.

tarafından

is it definitely a 2014? it might fall under this program : https://www.apple.com/support/macbookpro...

tarafından

Yorum Ekle

Yanıtını ekle

DocM sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 2

Her zaman: 122