Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Mağaza

A1418 / EMC 2833 / Late 2015 / 3.1 GHz Core i5 or 3.3GHz Core i7 Processor. Released October 13, 2015.

80 Soru Tümünü görüntüle

Slow CPU and High Fan after SSD Upgrade

I installed a OWC Mercury Electra 6G SSD in this late 2015 21.5 iMac. Previously it had a 1TB Fusion drive. It boots fine but the CPU is maxed out with kernel_task consuming all of the processor, and the fan is running at max speed.

I should also mention that during the installation, the screen fell open and the LCD cable was damaged. I have ordered a new LCD cable, but in the meantime, the built-in display does not work at all. I am running it on an external display. Could this be the cause of the system freaking out?

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

The display cable carries other signals in this case the thermal sensors. So when you damaged the cable you disconnected the sensors as well. SMC is designed to go into save mode when it looses access to needed sensors.

So until you replace the cable this is the correct reaction from the system. Hopefully no further damage is present.

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

I have mostly the same situation. Mid 2015 21.5in. Machine had a 2.5in stock laptop 1TB HDD in it. I swapped it out with a 1TB SSD (generic) after a clone.

Boots and looks fine. However, fans on high and very very slow.

As far as I know, these don't have temp sensors on the stock HDD. Didn't see one nor had to remove one from the stock drive. I didn't damage my vid cable as far as I could tell. I did however, buy a new LCD. Original was an (sd)(d2), this one is (SD)(D1).

tarafından

Ah! Todays HDDS & SSD's do have thermal sensors within them. Most are wired to SMART services, so your system can poll them.

The rub here is SMART is not so smart! To poll them you burn a CPU ACK Process, so excessive polling slows down your system, Apple went to the standards group to extend how SMART worked so it doesn't need the ACK. Newer drives which support the current SMART standard follow this enhancement. Otherwise you'll need a sensor.

So double check your drive as I'm sure its not too old or doesn't support the needed thermal aspect of SMART.

Even still! I think you'll also need to fix your displays cable and logic board connector as the displays thermal sensor maybe the one messing you up.

tarafından

Ok. Thanks man. I'll get a cable on order. The SSD in her now is: "Silicon Power 1TB SSD 3D NAND A55 SLC (SP001TBSS3A55S25)".

tarafından

@gfburke - This drive will need a shim as this drive is a slim design. Make sure you have that before you start. Otherwise it will be loose in the case.

tarafından

That little rubber bit seems to be pretty snug. But as far as we both can guess, LCD cable. yah? I wasn't sure if the sd d2 vs sd d1 was an issue or the drive needed some special thermal adapter. Thanks man.

I'll get "US For iMac 21.5" A1418 LCD Screen Display EDP Cable Mid 2014 Late 2015 2k" on order.

tarafından

2 tane daha yorum göster

Yorum Ekle

Did this fix resolve the problem.

I had someone do a RAM and SSD upgrade, it ran fine afterwards but the screen fell out that night. Since the screen has been replaced, the fan doesn’t stop running at full speed and it takes 15 minutes to open Adobe Premiere etc….

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Did you replace the display cable when you replaced the display? I would recommend running diagnostics, holding the D key when you boot the system. You might want to install a more useful app like TG Pro see what its diagnostic services tell you.

tarafından

Yorum Ekle

Yanıtını ekle

manuelw sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 10

Son 30 gün: 22

Her zaman: 690