Ana içeriğe geç

Food processor from Vorwerk manufactured and first distributed in 2014/2015 (Europe/US).

46 Soru Tümünü görüntüle

Should I self repair the TM5 scales?

The scales stopped working by just showing 0000 or max limit weight figures when pressing the lid down. A few days later the scales seem to have recovered its sensitiveness yet it appears to be too sensitive and readings show changes even when untouched.

Is it at all worth attempting to repair it or send it to be repaired?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
9 Yorum

I had that exact same problem myself. The scale on the thermomix TM5 went from 0 to MAX, after some pressure on the thermomix.

In addition to this I had the selector button, which jumped from time to time when selecting times and temperatures.

I fixed it without really understanding how.

I disassembled the thermomix, until I got to the weight sensors, I didn't see any kind of residue anyway I blew on the inside of the legs, although the sensors are solid pieces of aluminium.

When I reassembled the Thermomix, everything worked perfectly, just as it did on the first day.

If it helps anyone.


To fix this issue, Start the TM5, start the Motor and unplug the TM5 for at least 15 Minutes (hard shutdown). The scale recalibrates after the restart and should work properly.


Anyone know how the scale actually works? I've had the same problem (0-Max) and after opening the Thermomix and cleaning out legs and contacts it seemed to work ok, but the measurement it gives is not correct. it shows about 25% less. (measuring cup should be 40g, but the thermomix gives me 30g only)


I have same problem.. the measure is not correct. have advise to fix it up?


If you tried everything that is listed in this thread and its still not working then you might be out of luck and have to send it in for repair.


4 tane daha yorum göster

Yorum Ekle

4 Cevap

Filtre ölçütü:
Seçilen Çözüm

Facing the 0000/max scale issue, after some reading I decided to look into our TM5. I found somehow strange that some people fixed it “cleaning contacts” or just “disassembbling and re-assembling”. I’ve worked before with load cells, and they are “solid” devices, with soldered and glued connections in the cell end (no contacts to clean there).

So I looked at the mainboard end of the load cells wires, at the right back side of the board. While checking the connectors, I noticed that the wires from the three load cells (three groups of four wires each) run quite near the board components, even touching the board, and had ferrite beads around them to reduce electronic noise.

Load cells produce quite small voltage signals, so they are very sensitive to noise from board components. So I just pushed wires and beads some milimeters away from the board, checking they kept there after reassembling.

Now the scale works fine (I’m too lazy for further testing, maybe connecting an oscilloscope probe to load cells output while moving cables would confirm or discard this theory).

Hope this helps.

Bu yanıt yardımcı oldu mu?

Puan 12

21 Yorum:


I’ll check that. And come back with the results!! Thanks!!!


This worked great for me!

Ángel gave me the track with his technical description to isolate the problem.

I didn't want to disassembly the machine, so I thought that maybe if I could move the wires shaking the machine, it would work.

I tried shaking it upside down, didn't work. I tried shaking it in lateral movements, didn't work.

Then I shake the machine vertically, in its normal position from up to down, and I hit softly the base of the machine against my knee at the end of the movement from up to down while I was sat (not hitting the rubber feet, just in the space among them).

It worked!, the scales began to measure with 0,00 g. of error.

It clearly seems that the TM5 has a design problem, and the wires goes too close to some components that produce electric noise, altering the measuring signal.

Vorwerk should fix this design problem transparently instead of request the customers to send the machine to the technical service and return it without an explanation of the fail.

Many thanks Ángel!


Glad to help :-)


Just read this thread and took Sergio’s advice which fixed a scale that was going 0 - Max. Thanks Angel for the original inspiration and Sergio for trialling the quick fix.


Sergios method just worked for me too!! And I have been trying to fix this for ages. Please try it!! Had to try twice - second round of banging worked.


16 tane daha yorum göster

Yorum Ekle

Dissasembly Thermomix. Unscrew the 3 screws from the weight sensors. Set the sensors correctly and tighten the screws. The scale will work properly.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Also had the same fault with the scales not working. Disassembled unit removed the sensor feet, contact cleaned all parts and re assembled. All working ok now. Super happy

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle


First of all I would like thanks to Angel for his technical explanation.

I finally solved the problem opening the machine front panel and sticking the wires to the plastic of the case (behind of the electrical board).

Here you have a picture of the wires after I put some black adhesive band in order to stick them to the Thermomix case.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

John MacKay sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 6

Son 7 gün: 103

Son 30 gün: 467

Her zaman: 21,832