Ana içeriğe geç

Repair guides for the Surface Book 2 15", The 15 inch version of the hybrid laptop/tablet manufactured by Microsoft. This device was released in November 2017.

19 Soru Tümünü görüntüle

Constant Attaching/Detaching of Keyboard and tried obvious solutions

Recently I have come upon an issue where the keyboard keeps attaching and detaching intermittently.

I am no stranger to this issue over my 2 years of using this computer. Usually I have to just clean the connectors and it works again. If that doesn’t solve the problem right there, a hard reset (power + volume up held for 30 seconds) usually resolves this. Also I can tell it’s the connectors because moving the laptop around or adjusting the screen pivot usually triggers the issue reliably before I clean it.

However this time I am stumped. I have cleaned the connectors (both the keyboard and computer side) thoroughly with rubbing alcohol. The screen can attach fine no problem and everything is working. Moving the monitor around, shaking the laptop, gentle taps, don’t trigger any upset to the connection. However the computer is now attaching and detaching constantly regardless of the conditions (moving or not moving).

The timing of this can be as fast as 10 seconds apart and as slow as 5 minutes apart between attaching/detaching interruptions. When it is ‘detached’ on many occasions the keyboard and mouse still work. Other times it actually interrupts their functionality.

Things I tried:

  • hard reset multiple times
  • cleaning thoroughly the connectors
  • making sure windows is updated
  • making sure drivers are updated

Only thing I haven’t done yet is a full hard reset. Looking to get my files/programs in order to do a full wipe and hope for the best.

The computer was working perfectly until after one quick site visit where I reattached the keyboard and used it as a bulky tablet. Right after I put it back into it’s original laptop form, the issue popped up. I keep thinking it’s physical but I am not sure what the cause could be. My highest suspicion revolves around the cable that runs along the hinge of the keyboard, connecting it to the pins (only a suspicion, I am not sure as tilting the monitor doesn’t cause any detaching issues directly). But I am at a loss as to how to check or deal with that.

Sorry for the long description but if there are any thoughts I can try I would love to hear them. I am out of warranty so dealing with Microsoft is a no go.

Thank you!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
Yorum Ekle

9 Cevap

Filtre ölçütü:

It's also possible that it's a hardware failure.

Firstly check out the Microsoft tutorials on Fix problems detaching or attaching your Surface Book keyboard.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Hi Doug, this was a great breakdown of the issue. I am having the exact same issue, even having trouble just typing this response. I did want to share one thing that seemed to help for a time. If you go into task manager, stop the Surface DTX Service. Good luck, hope we both find a more permanent solution.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

I had this very annoying problem and just accidentally fixed it.

I was trying to clean the slots on the underside of the screen and I popped off the plate that surrounds them. I noticed that there was crud under the plate so I cleaned it out and, low and behold, 2 tiny magnets appeared under the crud.

After cleaning them I put the plate back on and the problem is totally gone.

Apparently the surfacebook uses those magnets to know its attached and if enough crud gets in the way they stop working reliably.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Can you give more detail on where the magnets are located?

tarafından

UGH OMG ive been cleaning these ports for AGES and never thought to clean the top of the male side of the connector. THANK YOU

tarafından

Hey Jeffery, can you help me locate where the magnets is and how you popped off the plates and all that. I have exact same problem as yours.

Here is my email: yahyazakaria771@gmail.com

Facebook: Yahya Alkhateeb

Thanks

tarafından

hello~ can you help me too?

where the magnets is and how you popped off the plates and all that. I have exact same problem as yours.

Here is my email: anthony91@suwoncca.org

thanks

tarafından

Hey can u guys help me tooo i have this problem for a year now and it just started today only my email is jaskaransgofficial@gmail.com

tarafından

Yorum Ekle

I don’t know everything I tried…. ha.

I actually just went out and got a Bluetooth keyboard and when I hooked it up the disconnecting problem went away. I picked up an small Anker brand at Walmart. I have uninstalled it and installed it a couple of times when the problem came back after updates. I am glad I didn’t return it after everything started working again. Knock on wood it keeps fixing the problem. I don’t think I will update for awhile to keep the magic going. Good luck.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

I had a similar problem and was solved the same way, I think it is a flaw in the design that led to problems in use. It is very unfortunate that the manufacturer has made such mistakes that directly affect the user experience. Because of such flaws I had problems with the work on the project site https://studyhippo.com/essays-by-categor... with ready essay samples of homework. I had to give up this device. I think that in time all the shortcomings will be corrected and then this product will definitely find its buyer.

tarafından

Yorum Ekle

Hi Doug. I am having this exact same issue. In frustration, I stopped using my SB for about 3 weeks. When I turned it back on, the problem had disappeared. Unfortunately, after 2 days, it returned. I have tried every proposed fix I could find online, but nothing has worked. Did you ever find a permanent solution? Thanks, Sean.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

I have been having the same issue. Typing also triggers the detachment. The light turns green and my processes freeze. Also my five and six keys do not work along with my tab key. I have tried everything above. This is the second surface book (I have the OG surface book) and I had to return it. I really don’t want to keep starting over on a whole new hard drive. Also, with no stores I have to mail it in and pray it comes back in a timely manner. I can’t be without my device for long. I run my business from it. Ugh. Best of luck to you all.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Mine plainly came back to good working order on its own. Guys, it's so weird! I sent mine to post-warranty and they returned it saying that the fluid marker was activated and that they could only replace the whole Dock board for around 1800 euros. I told them to return it to me because other than maybe vapour or condensation there was no fluid contact with the laptop and that their solution is absurd! I changed my laptop from SB2 to another because I couldn't work like that (i.e. with an external keyboard) and after a year on the shelf, when a friend asked if he could use it as a desktop replacement at home, we just figured it worked just as before (this after all the updates - many - were made)… so, my SB2 works great now!

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Using rubbing alcohol to clean the pins on the connectors helps. This was the last thing I tried because the pins looked clean to me. It was surprsing that it worked. Use compressed air to clean the connectors on the display part if you have a can of it.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Hi.

I have exactly the same problem. I've done everything you discribe plus a total reset. Nthe error is still present..

It shows when i'm working with word or using file explorer.,

Did you find a solution on your side ?

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Doug Tempest sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 4

Son 7 gün: 62

Son 30 gün: 297

Her zaman: 8,352