Ana içeriğe geç

The G4 Quicksilver came in 533MHz, 667MHz, 733MHz, 800MHz, 933MHz, And 1.0GHz speeds.

49 Soru Tümünü görüntüle

Powers up but with no chime and a black screen.

I have a Power Mac G4 Quicksilver 2002 800MHz that will power on when the power button is pressed but will not boot. The button will illuminate but only when it is being pressed. All the fans except for the CPU/logic board fan spins up. The red diagnostic light on the motherboard lights up when the Power Mac is on. The hard drive appears not to be spinning up when the Power Mac is on. There is no chime and a black screen as well. If I press and hold the power button the Power Mac does turn off. I can also power on the Power Mac with an iMac G3 keyboard that has a power button on it, but I cannot use the same button to turn the Power Mac off. I have replaced the PMU battery and pressed the CUDA button and also tried different RAM sticks, but the Power Mac is still acting the same. I’ve even powered it on with no sticks of RAM in it to see if I’d get an error beep code, but the Power Mac still does the same thing. I’m guessing that the power supply would be the problem but they are expensive when looking on eBay so I wanted to know if there are any other things I can try first that could possibly fix the issue. Any help would be greatly appreciated!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:

Most likely a bad logic board.

Bu yanıt yardımcı oldu mu?

Puan 0

5 Yorum:

Thanks for your answer! I guess that could explain why the CPU/motherboard fan does not spin up. Is there any way I can test the motherboard?


While the screen is off turn on the computer look for LED's on the motherboard near the middle. But be safe don't touch the part of the motherboard on the top left because it can shock the living !&&* out of you (120 volts)

If you found my answer helpful please accept it as a solution thank you!


As I said in the first post, the red LED is turned on when the Power Mac is powered on. I believe that is the only LED indicator that is on the board. Because that LED is on, does that mean that the logic board is working or is it not the issue?


Update: I did some more work on the motherboard and decided to reseat the CPU. I tried booting the Power Mac with no CPU inserted just to see if I got a different result. The red LED diagnostic light was on but no fans were spinning. I then reseated the CPU and tried again but it still has the same issue. I also tried booting with no cables connected to the hard drive and optical drive, which actually caused them to spin up/power on, but the Power Mac still did not boot. However, I might know what is causing this issue. I measured the voltage coming from the CPU fan socket and the P4 connector which both read around 12.13V, which is in range. The CPU fan does not work even with the right power. When I removed the CPU to reseat it, the thermal paste was hard and there wasn't much left on the CPU. Not surprising for an old computer. Anyways, I'm starting to think that the CPU overheated too many times and then became permanently damaged. Should I buy a replacement CPU on eBay for the Power Mac?


If you really care about the mac and you can blow some cash on it, go right ahead. But at this point I would just recommend buying or building a new computer.


Yorum Ekle

Yanıtını ekle

Trevor Lamb sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 5

Son 30 gün: 27

Her zaman: 744