Ana içeriğe geç

A 10.1" touchscreen tablet released in 2014 by RCA Corporation.

40 Soru Tümünü görüntüle

RCA tablet (RCT6203W46 KC) won't charge

My 10" RCA tablet (RCT6203W46 KC) won't charge; tried numerous chargers which work on other devices and on my 7" RCA tablet. I've tried power banks and AC chargers. The connection on the tablet itself seems loose. When I hold the charger in the tablet, the battery symbol comes on but I can't sit there for hours holding the charger. I've tried lodging the charger cord securely to the tablet but it is too loose to sit securely. Battery is completely dead at this point.

Is there a fix for this or is it a lost cause?

Thank you.

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Hi @mapram1 ,

Sounds as though the USB connector is loose from the system board.

Here’s the ifixit RCA RCT6203W46 Battery Replacement guide that shows how to replace the battery in the tablet. I realize that this is not the problem but it is handy as it shows how to open the tablet so that the USB port can be checked.

The USB charge port is a smd (surface mount device) type component, mounted directly on the systemboard, so you will need smd soldering skills and tools to do the repair. Either resoldering the connector to the board or replacing it if it is faulty.

Here’s a link to just one supplier of the part to give you an idea of what it looks like and how much it may cost. There are other suppliers online that may suit you better. Just search for RCT6203W46 USB port part to get results.

If doing the repair yourself seems too daunting, contact a mobile phone or electronics repair service and ask for a quote. If you supply the part it may make it quicker if they don’t have the correct one and have to order it in. Just a thought.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

MARY sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 4

Son 30 gün: 8

Her zaman: 138