Ana içeriğe geç

Repair and information guide for the Whirlpool ET8CHM*K*0* refrigerator, a top freezer model without an ice dispenser, equipped with an anti-sweat heater switch, introduced in 2001. This page covers information for model numbers matching the pattern ET8CHM*K*0*.

1 Soru Tümünü görüntüle

Whirlpool et8chmxkb04 defrosts for a while then I can't get it to work

Can someone please help. My whirpool fridge coils freeze up and the heater won’t turn on to thaw them. I replaced the thermostat, heater, timer twice, wiring harness, fan motor unit. It seems to work after I see a spark while connecting the heater wires temporarily (yeah I know it should be unplugged). It defrosts for a week or two (sometimes less) then I can't get it to work? Why would it work for a while after sparking? Thanks for any help I've been messing with this thing for a while now, years. Its a whirpool with the freezer on the top from 2004. The fridge is model number ET8CHMXKB04.

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Hi @greengiant27 ,

When you say “thermostat” do you mean the defrost thermostat - part #32 liner parts diagram? If not there are plenty of videos on YouTube how to test a bi metal thermostat

Also have you checked that the compressor overload protector and start relay part #s 13 & 13A unit parts diagram are OK?

Update (09/28/2020)

Hi @greengiant27 ,

Initially it may be safer to use an Ohmmeter to check for continuity in the wiring from the heater’s harness connection.

Disconnect the power from the fridge and then disconnect the heater from the wiring harness and test the wires that are coming to the heater, not the wires from the heater.

I cannot find a wiring diagram or a service manual for your model but here’s an image that has two circuits that show how it might be wired. I’ve drawn in arrow points where to connect the Ohmmeter. It tests the wiring path between the components and the supply

As I said it might be the same or similar to your model, but then again maybe not. Check what colours the wires are as that may also help to identify if it might be the wire you need to connect to with the meter. The Neutral wire should be white or grey. As for the others they are shown on the diagrams but they may be different in your model.

If either wiring diagram is not similar then you will have to connect the Voltmeter in place of the heater (or between the heater and earth with the heater still connected) and check.

Turn off the power and jam the meter leads in the heater harness plug connector so that you don’t have to be holding them and then turn on the power. Turn off the power before touching them again.

Unfortunately, I don’t know how to force a defrost cycle in your model so I don’t know how long you’d have to wait before it enters the defrost cycle so that you can test

Block Image

(click on image to enlarge for better viewing)

I realize that you said that you replaced the defrost thermostat but here’s a video that shows how to test if one is OK and it also has good information about how to find out at what temperature they release and then re-operate, as the defrost thermostat does play a big part in the heater operate circuit.

In the circuit on the left it actually closes and opens the heater circuit so the timer can still cause a defrost cycle to commence and cease but there may not be a heater circuit. In the one on the right it opens the timer and the heater circuit so if the timer has no power then there will never be a defrost cycle.

Bu yanıt yardımcı oldu mu?

Puan 1

9 Yorum:

Yes part #32 is it. I have not checked the compressor overload protector or start relay. I didn't think those had anything to do with the unit not defrosting? Can you explain please. thanks

tarafından

Just to add to my initial post. The coils are freezing up and the heater won't turn on to thaw them.

tarafından

@greengiant27

When you said "It defrosts for a while then I can't get it to work? " I was thinking that it did start to defrost and when the thermostat operated to signal the end of the defrost cycle, the timer should turn on the compressor again and it didn't start. maybe I misunderstood

tarafından

I could have explained it a little better sorry.

tarafından

@greengiant27

No worries I think I understand what you meant now ;-)

Did you use a Voltmeter to check if the power is there for the heater for the required full amount of time for the defrost cycle? Be safety aware as usually it will be full mains supply voltage i.e. 120V AC

If it is just wondering if the drain tube was blocked preventing the meltwater from draining to the evap pan under the fridge, therefore ice will buildup when the compressor is restarted and the meltwater refreezes again

tarafından

4 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Dan sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 8

Son 30 gün: 10

Her zaman: 128