Why Did My New Hard Drive Work One Minute, But Not The Other?

So I followed the steps that were laid out to install a new hard drive in my mid 2010 MacBook... took out the stock 320GB Seagate drive, running at 5400 rpms, and replaced it with a 750GB Hitachi , running 7200.

I was going to get the the 7200 rpm drive offered by iFixit, but the one I got had a higher rating, plus was cheater, on Tiger Direct.

Anyhow, I reinstalled everything via Time Machine and EVERYTHING was working perfectly! Until I decided to restart the machine. After being black, I'd get the Apple logo, plus the spinning thing, and then... the Apple logo would vanish, but the spinning thing would return, then disappear, and then reappear. Over and over again.

I tried booting into Lion's built in recovery drive, but nothing. Same with booting off a CD. And when I swapped back in the original drive. everything's back to normal.

Huh? I doubt iFixit would sell a 7200 rpm drive for the machine if there was a capability issue. A friend stated that maybe the Mac doesn't have enough juice the operate the drive, but it was running flawlessly when I installed the OS and test drove the machine. Do I have a bad drive or something? I'm super confused!

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Reformat the drive using Disk Utility from the installation DVD and give it one partition, then install your system. Try it, then use migration asst.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

But again, the new hard drive accepted the OS without issue... it worked for a while. But then stopped after restarting my computer.

tarafından

Use the "write zeros" option when reformatting to map out any bad blocks.

tarafından

No offense, but I don't think you're really understanding or listening to what I have to say.

The drive worked fine for a while, but then would not boot up at all! I can't even boot into the Recovery Disk to launch Disk Utility in the first place, as explained above.

tarafından

Yorum Ekle

Yanıtını ekle

fortninety sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 381