Ana içeriğe geç

The spiritual successor to the Chromebook Pixel, the Google Pixelbook was unveiled at the 2017. Made by Google event, and made available October 31st, 2017. Model number: C0A.

19 Soru Tümünü görüntüle

Cannot boot. Screen stays black.

This is a Google Pixelbook (i5, 8 GB RAM, 128GB) bought in 2018 and out of warranty.

Last Sunday, after a software update, pixelbook rebooted andafter a while the screen turned black and since then I haven’t been able to boot it up.

When I plug the charger, led is solid green. But if I try a boot, a hard reset, or anythin else, nothing happens (except at the led level there is some activity)

I have a case opened at google support but because this is out of warranty, agent was pessimistic that they can do anything.

Here it what I have already tested:

  • standard boot but pushing power button: nothing
  • hardware reset - Holding refresh and pressing power
  • recovery mode - Holding Refresh and Escape and pressing power
  • another one - Connect the charger to the Chrome OS device. Hold the side power button + Refresh key  and remove the power adapter as they keep holding on those buttons. Wait for 1 minute. Press the side power button to test the device. Connect the power adapter and monitor the LED color. Device should try to turn on and LED should blink or have solid color.

Nothing has helped so I guess there is an hardware issue. Do you think it could be the motherboard to be replaced ? I am tempted to try to follow - Google Pixelbook Motherboard Replacement

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Hi There,

Another thing you can try yourself is to check if the problem is not just a loose component, you’ll need to open up some/all of the panels though.

First thing to try is to remove and re-seat the “easy to get to” components like the RAM and SSD/HDD etc.

Also take out the main battery whilst testing, it should be able to start up with the AC adapter alone.

A bit more advanced but do-able check is to take the CPU off and re-seat it. but for this you’ll need to get some new thermal compound and you’ll need to remove the old compound with some q-tips and rubbing alcohol from the heatsink and CPU before assembling back together.

If it still doesn’t work then the next step is a complete disassembly and testing all components unfortunately, for this it’ll be best to take it in to a repair shop that has the proper spares / testing equipment on hand.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Did you ever manage to get the issue resolved?

I've got a Pixelbook C0A here that's also playing dead. Same symptoms as yours, the only difference is, Esc+Refresh and Power Button launches recovery mode ok.

I've created and tried 3 difference recovery images v15662.64.0, v15662.35.0 (Beta) and v15437.84.0.

The recovery completes ok, tells me to remove the USB to restart automatically. When I remove the USB, the screen goes blank and it doesn't reboot/boot. It goes back to playing dead again.

The battery is definitely charging ok as the charging LED went from white to green and I can power up in recovery mode on just battery.

Makes me think Google pushed out a dodgy OS update rather than there being any kind of hardware issue.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

I have the same problem today on my PixelBook. I am going to try to at least get into the Recovery mode.


Yorum Ekle

Yanıtını ekle

Guillaume RAMELET sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 9

Son 30 gün: 44

Her zaman: 2,733