Ana içeriğe geç

Repair and disassembly information for Samsung's flagship S20+ Android smartphone, released in March of 2020.

15 Soru Tümünü görüntüle

No network after screen replacement

Replaced the screen/frame on an AT&T S20 Plus, transferred over all parts including front camera, charging daughterboard, 5G antennas, etc. After sealing it back up, it’s not detecting the cellular network. Fearing a bad part, I put it back in the original screen/frame and same thing. All connectors look fine, pressure pins on the charging port are in good condition, too. Anyone have any ideas? Thanks in advance!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 6
Yorum Ekle

3 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Block Image

Block Image

I know on a S21 Ultra, I did a screen assembly swap and the part was identical but once I powered it up I had the same issue. Not a single answer made sense. Finally someone mentioned replacing the screen assembly fixed there’s. I dug deep into the screen assembly and learned there is a small antenna flex on the corner and it’s held down by tri-wing screws. It turns out they aren’t universal. The “international” assembly uses a different band antenna. So I swapped my original flex and instantly had a signal again but this time it actually worked on the AT&T network. What an ordeal! Maybe the S20 is similar? As it turned out, the SM-G998U uses a different version of this LTE/4G antenna than the screen used on the “B” variant (SM-G998B)

Bu yanıt yardımcı oldu mu?

Puan 4

Yorumlar:

We found the same thing and it seems swapping the flex works sometimes. It'd be easier if suppliers were a little more open about their "U" model service packs actually being "F" models.

tarafından

Yep same thing! Took me hours to narrow it down

tarafından

Can you tell me where this Flex antenna is located? I just swapped all the internals of my Canadian s20 plus to a replacement screen frame and I'm having the same issue. Thank you

tarafından

Looking into the old frame, should be upper right side, runs against the inside. There are about 4-5 torx screws and some adhesive holding the connector down. The new frame may will have a very similar part except it will have a slightly different “type” printed on the connector. Like NA or int. It may not even have one. Just carefully transfer the one from old frame to new one.

tarafından

I think I know where you're talking about. I think that's where the 5g antenna is. My Canadian s20plus doesnt have that antenna on the mid frame. It's just a empty slot on the old frame

tarafından

1 tane daha yorum göster

Yorum Ekle

It’s not the 5g slot with 2-Philips screws… it’s pushed up into the frame. I used to have a picture. “Flex” it’s a ribbon with 4-5 attached hold down screw slots it’s L shaped to fit in upper top and right side.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

On an AT&T S20 Plus, I replaced the screen/frame and transferred over all parts, including the front camera, charging daughterboard, 5G antennas, and so on. After resealing it, it no longer detects the cellular network. Fearing a bad part, I returned it to the original screen/frame and the same thing happened. All connectors appear to be in good condition, as do the pressure pins on the charging port. Anyone have any suggestions? Best Medical Billing Services Thank you ahead of time!

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Brann Kelley sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 14

Son 7 gün: 120

Son 30 gün: 463

Her zaman: 3,541