Ana içeriğe geç

Model: C11CD10201 Print/Copy/Scan/Fax Auto Document Feeder Will print on both sides of page Wifi / Inkjet

3 Soru Tümünü görüntüle

Problem downgrading the firmware of an Epson WF-7840

Good morning everyone,

I've had the bad idea to upgrade the firmware of our Epson WF-7840 (version CD17M6 now).

Now, our non epson cartridges are not recognised anymore.

I've search the web about how to downgrade the firmware. I found the procedure, found how to put the printer in "recovery mode" and, on the Epson website, I found the "Recovery Mode Firmware version CB08LC" for the Epson WF-7840.

But it doesn't work...

First problem, the model of the printer does not appear in the "Epson firmware updater" but it sees that a printer is connected.

Second problem, and it is where it stops, when I launch the Update, it fails with a message on the printer's screen "Data file not found".

I tried with my mac (macbook pro 16" m1 max) and with an older macbook pro from 2009 with the same result. I tried with another USB cable and still no luck.

What am I doing wrong?

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

3 Cevap

Filtre ölçütü:
En Yararlı Yanıt

In order to fix the problem you need to reinstall FWCH67TL_CD08M4 .This can be done tricking the updater swapping the file during the update .

Go to the temp directory on the C:\Users\Your-Username\AppData\Local\Temp, you should find a Epson directory run the FWCH67TL_CD08M4.exe, now on the temp directory above you will find a directory called Firmware Updater() copy the file FWCH67TL in a safe place (this is the firmware you want).

Close the updater now run FWCH67TL_CD17M6.exe you will find in the Temp directory a new Firmware Updater() directory swap the file FWCH67T to the file you have previously saved continue the update overriding the firmware on the printer.

This should work for any other updated firmware.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

Where to find the old firmware files?

tarafından

@Paul Muir These don't appear to be the files listed in the thread above

tarafından

Yorum Ekle

I had this exact problem. Couldn't figure it out for months. Then, suddenly, I tried one last time, but this time I used the firmware update for another similar model, the EC-C7000. The Firmware version is different. But in my disbelief it worked. I'm still in shock. The CD08M4 version firmware update didn't work for me no matter what I did. But for some reason this other CD17M6 did the trick. Epson is a tricky bastard. I urge you to try it. You can find the version I used on the Epson website here:

https://epson.ca/Support/Printers/All-In...

Just be sure to let the printer do it's thing. The lights will flicker randomly, and after about two minutes the printer will turn off on its own. Once that happens you can press the power button and viola....

Good luck and godspeed.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Try this steps-

Turn off the printer

A. For Epson XP-330, Epson XP-430 and Epson XP-434

While the printer is off, press and hold home, power, left arrow and cancel buttons at the same time, until ROM menu appears on your printer's display.

Epson XP-430 printer display

B. For Epson XP-340, Epson XP-440 and Epson XP-446

While the printer is off, press and hold power, down arrow, left arrow and cancel buttons at the same time, until your ROM menu appears on your printer's display.

Epson XP-340 printer display

Download and run the older version of the firmware installation package on your computer. Visit Drivers Collection and use their search function to find the firmware that you need. Input your printer 'Downgrade to Firmware version' as your keyword. Find and download the right version for your operating system (MacOs or Windows).

Click on the 'Next' button to start the installation.

Agree to the terms and click on 'Next' button to continue.

Click 'Next' to continue.

Click 'Yes' to overwrite the updated firmware.

IMPORTANT: Make sure that the printer power is always on and doesn't get interrupted beyond this point. Otherwise, the printer might be damaged beyond repair.

Click 'Start' to begin the installation.

Check on your printer and wait until the word Finished! appears on the display.

Epson printer screen display

Go back to your computer, and click the 'Finish' button on installer to complete the installation.

Epson printer screen display

Disconnect the power cable from the back of the printer, and then reconnect.

Finally, turn your printer back on. At this point, error message 'Wrong ink tanks' might still appear on your printer screen. To clear this message, you will need to remove all the cartridges, and then reinstall them. After that, you should be able to start printing with your compatible T288 ink cartridge again.

We hope that the steps above helped you to undo Epson firmware update, perform an Epson printer firmware reset, or downgrade. If you have questions or clarifications about this Epson firmware downgrade guide or any other concerns, you can contact ComboInk's Customer Service department. Call our toll-free number: 1-833-786-1266 from Mondays to Fridays from 6am-6pm PT.

Regards,

Rachel Gomez

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Arnaud Bour sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 13

Son 7 gün: 49

Son 30 gün: 215

Her zaman: 384