Ana içeriğe geç

Swedish company Tylö sauna heaters and control panels

1 Soru Tümünü görüntüle

"Pure" Controller Flashing 4 LEDs, but not initializing.

Hi, today I'm troubleshooting a Tylö sauna heater.

Block Image

The manuals for the Pure controller, and other YouTube videos suggest that the four top LEDs (Light, Door Contact, Delayed start, Heater) should stop flashing within a reasonable amount of time as the controller and main board PCBs synchronize.

In my case, they will not stop flashing. Any idea what this error suggests?

I've created the device page and added the respective user manuals and a troubleshooting document.

Below is an image of the flashing lights. Eventually, the top red dashed temperature display light will turn off, and the indicators will continue flashing.

Block Image

Update (03/05/2023)

240 V coming in. Heating elements read 24Ω each.

Tested continuity on the wire to the electrodes, passed. One electrode (White, Mid) had some carbon buildup, but nothing too irregular. Cleaned with scotch-brite and replaced.

Block Image

Block Image

Block Image

Block Image

Update (03/05/2023)

Unit doesn't appear to have a glass fuse.

Block Image

Update (03/05/2023)

(From manual) The temperature cut-out

The heater's temperature protection devices:

• PCB - The temperature cut-out on the PCB in the heater is designed to prevent components being damaged by overheating. If the cut-out activates, an error code shows (Combi Pure error code only) on the control panel display. If the overheating cut-out has activated, the heater cannot be started again until the temperature has dropped down 20 degrees (ºC) on the PCB.

• Water reservoir - The temperature cut-out in the reservoir is designed to protect the heater element from boiling dry. There is a red reset button under the heater which must be pressed in (see Fig. 9). If the cut-out has activated, the button will feel stiff and will 'click' when reset. If the cut-out has not activated and after resetting, the button will feel springy.

• Heater - The temperature cut-out in the heater is there to protect the components, pipe elements and woodwork in the sauna from overheating. There is a red reset button under the heater which must be pressed in (see Fig. 9). If the cut-out has activated, the button will feel stiff and will 'click' when reset. If the cut-out has not activated and after resetting, the button will feel springy.

Information! When the overheating cut-out activates, always check the cause of the problem. The service life of the tubular elements and PCB can be adversely eff ected by each overheating. Recurring overheating can be an indication of the following: Ventilation deficient? Room volume? Internal heater fault? Water reservoir not properly cleaned?

Update (03/06/2023)

Mike Wynn from Saunafin says "It is a communication issue. If you purchased from us (which I did not) please contact the office. If not, contact Tylö tech. If new, install you can try alternate control jack. See our documents page for link to troubleshooting."

I'm wondering if the comm. issue is on the controller side or the unit pcb side. Might be hard to replace that RJ10 board.

@jayeff The numbers 1-10 do not show up. The unit hasn't initialized, so not the error codes mentioned in the pdf. Here's a reference to what the bottom of the unit looks like. I did not install or buy this client's unit, so I'm not sure if the fuses were skipped, or this is stock. It does however disagree with the manual's photo I shared above.

Block Image

I'm waiting to hear back from Saunafin and Tylö to see if they can offer any more help.

Update (03/22/23)

Found thermocouple with detached wires. While this shouldn't affect startup, the NTC needs replacing.

Block Image

I was able to reach Sauna360 technical support — Sauna360 oversees Tylö, Helo, Kastor, Finnleo, and Amerec in the US — and spoke with Nick (18003466536 ext 312). He helped troubleshoot rather quickly that the controller was not syncing with the board. A red led would have appeared on the board to indicate successful pairing. After moving the RJ cable to another white port on the board, the controller still did not connect.

Luckily, I had 1 day left for the warranty! He'll be sending me parts, and I'll follow up afterwards. Thanks Nick.

Update (04/17/23)

The previous owner didn't allow for any wire slack within the walls, and so the RJ11 controller cable was found to be faulty. A red LED is now showing, which signals that there is a successful connection between the main board and the controller.

Replaced the RJ11 leading to the control module, and everything booted up just fine. Unfortunately, the tab on the connector broke and it will not stay in place. I've ordered more connectors and will replace this week.

I was able to run a full heat and steam cycle. Just need to clean up the wire runs and do a little bit of trim work. My friend is impatiently awaiting the repair, and I'm realizing how helpful having a stockpile of different sized connectors and wires is. These kinds of jobs can go on for a long time waiting for parts to ship.

Update (06/09/23)

The unit will run for a cycle or kick off a few minutes in before the dreaded flashing lights on the controller. After lowering the heavy unit off the wall — which I sometimes leave filled with rocks for the extra workout and strain — I'll move the RJ connector between the 4 ports on the board. Like a cat with 4 lives, the unit has worked for one cycle or less per port. This cat is out of lives. I called Ron at Finnleo (18003466536 ext 325) and explained my troubleshooting process, and he's sending me a new control board from the Minnesota warehouse. My fingers are crossed, and the crosses they are forming are myriad. Will update again after the new board is installed. My client is losing hope. This makes service call #8 to a home in the country.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3
3 Yorum

Hi @ngurney

Do any of the numbers 1-10 on the controller, turn on or flash at all?

If so go to p.51 of the user manual to see what the error code means.

You say that the "unit" doesn't appear to have a glass fuse. Is there provision for a fuse in the unit as shown in the image you posted?

Not having a fuse, glass or otherwise (ceramic cartridge?) when there's provision for one by way of a fuse holder might be worth looking at.

tarafından

Hi @ngurney,

Is there a model number somewhere on the unit in your images?

Can't see it too well but is there a fuse somewhere on the pcb in your images? Just wondering if instead of a user replaceable fuse as shown in your image above they opted for one on the board

tarafından

@jayeff Serial Number# 44105607

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

After much ado, and troubleshooting nearly every system component, I received and and replaced the PCA (printed circuit assembly). The RJ ports on the old board seemed to wiggle around a bit. My assumption was that heat cycling damaged the connections and caused miscommunication with the control unit. I inspected the board and didn't see any other obvious solder joint issues.

Block Image

Block Image

This took about 10 minutes and two screws, two clip fasteners, and about 20 labelled wires...with matching labels on the board! The spade connectors came off much easier with a flathead.

I flipped the breaker, and rebooted the machine. The sauna booted right up.

The most unfortunate part of this repair is that the local weather read 103 deg F (40 deg C), and it seems the cold part of the year is over with. I can't wait to use the unit in the fall!

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

nicO sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 9

Son 30 gün: 50

Her zaman: 537