Ana içeriğe geç

Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

383 Soru Tümünü görüntüle

Few vertical lines appear quickly then goes black

This happened after I cleaned my LED backlight board and my power supply.

Before I cleaned them up, my iMac kept dying if there was any 'heavy' graphics-related job. Now, that issue is fixed(which means that I can run some graphics-related programs), but I get a few vertical lines appearing for a split second then the screen goes black.

The strange part is that it runs okay when it's in the boot stage(when the Apple logo appears, or when it gets to the boot selector, etc), but it doesn't right after it runs its OS.

Edit: I've also upgraded my CPU from i3 550 to i7 860.

Update (07/11/23)

@danj Great news! The graphics card is alive. Check the picture here: https://imgur.com/a/WYqWB2i

Block Image

Now I wonder what's the problem... Maybe the LED board? I mean since it also controls the display's vsync timing so...

Edit: I tried booting to macOS Recovery and realized that the display works(without any lines, just as clear as it should be) if the external display is plugged in and breaks when I unplug it. The funny thing is that I can replug it to revive the iMac display.

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

iMac’s leverage the Intel CPU’s graphics engine at startup. Then, the MXM graphics board GPU takes over.

So as an example if you restart your system using the Startup key options you can stay with the Intel graphics will still be active.

Sadly, it’s likely the system an MXM board needs some cleaning and replacing of it’s TIM both paste and pads.

I would install a good thermal management App like TG-Pro which I find is the best! As you need to see clearly what’s happening and boost the fans to help keep things cool.

Bu yanıt yardımcı oldu mu?

Puan 2

21 Yorum:

Does overheating cause vertical lines and etc? I'll try this but I don't think it's a thermal-related issue tho.

tarafından

@helloyunho - yes overheating can cause this. But unless you see the systems thermal sensors you won’t know. The graphics board has its own cooler and fan. Even still the thermal paste and VRAM chips thermal pads lose there effectiveness with age.

Otherwise the display it’s self has issues.

tarafından

So it's been about 3 months and it still doesn't work. What I did was:

1. Clean and reapply the thermal compound

2. Adjust the fan to spin based on GPU's temperature

Again, I think this is a hardware issue and not something fixable on the software side.

tarafından

@helloyunho - What did TG-Pro tell you?

Without the data we can’t help you😩

tarafından

@danj Sadly I use Linux on my iMac, so what I did was installing mbpfan kernel module(and yes it works on iMac as well).

tarafından

16 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Helloyunho sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 5

Son 30 gün: 10

Her zaman: 134