Ana içeriğe geç

Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

591 Soru Tümünü görüntüle

will not boot to User

When i try to log into my computer i see the wallpaper and then suddenly it switches back to a grey screen. this then re-loads the wallpaper, then grey screen. looping over and over. i have tried to reinstall lion, still the same issue. i have tried a new hard drive with fresh install, this works fine. hard drive passing techtools tests and also disk utilities verify disk.

booting into safe mode shows the le actual log in window, when pressing enter i get the grey screen and back to the login window. is there something i can do here without formatting the drive? thank you for your help

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan -1
5 Yorum

Did you run Apples 'Disk Utility' to repair the permissions on the drive? If not give that a try.


Yes i have tried this. it found a few issues and repaired but nothing more than expected. i have also tried resetting PRAM and SMC just incase.


OK, Do you have the install DC/DVD's that came with your system or have a logo'ed OS CD/DVD to boot from? Or an external disk with a working OS on it to switch to? If using a CD/DVD or external disk works then you have something on your internal disk thats messing you up - Refresh the OS on it.


I don't mean to sound a bit arsey but did you not read my actual post? thanks for the help but i have already stated that i have tried these solutions.


Yep, read them ;-} Was a little confusing so need to restate things. OK, so it's fine running on the external Right? (not the re-installed OS on the internal HD).


Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hi, I happened to read your post. Pretty frustrating. There's a way of course.

Boot into Single-User Mode. How? Turn on the Mac. When heard the chime, hold Command+S keys.

Mound the HD. Once Single-User Mode loads (black screen), type in:

/sbin/mount -uw /

Remove the 'Setup has been completed' file. How? Type in:

/rm /var/db/ .applesetupdone

Why such? This delete the file '.applesetupdone' in the /var/db/ director which checks on Startup to make sure the Mac has been setup. Since you have a problem somewhere around, we are resetting it creating a new Administrator Account.

Now, you reboot after the aforementioned command being typed in. How?

Simply type in: reboot and hit return.

Here what happens is your computer restarts and walks on with you as if it has been turned on for the first time so please walk through accordingly.

Once you continue Setup, make sure to select 'DO NOT TRANSFER MY DATA'. Why? Because you don't want to see the same grey screen loop again. Once you complete the simple setup as guided by your computer, come to the new user (Admin) account. And if you need, you can backup your files, music, media, act from your old user account because it has been saved in your USERS folder as "OLD USER". While setting up a new USER or ADMIN as we discussed, just make sure that you are not giving the same Old Name. Give it a new so that overwritten probability is secured.

Let me know if you're successful. My site is: Can leave me a written message from there too.


Bu yanıt yardımcı oldu mu?

Puan 3

1 Yorum:

Thank you so much, i was able to log into the mac now and back up all the data. do you have any idea of what may have caused this? i do not have much software installed on here other than Office, Skype and Olympus Sonority.


Yorum Ekle

Yanıtını ekle

Macfan1463 sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 764