Ana içeriğe geç

The Early 2009 Mac Pro—also known as the Mac Pro 4,1—introduced Intel's Nehalem architecture to Apple's line of professional desktop computers in March 2009. The Mac Pro 5,1 used the same interior design but received further CPU updates in 2010 and 2012.

199 Soru Tümünü görüntüle

Computer boots into Ubuntu just fine, but skips the bootloader screen


I'm really keen to give my Mac Pro (Mid 2012) a second life as a Plex server. The problem is, last time I was tinkering with it (2 years ago), I loaded Ubuntu on it and messed up the bootloader while trying to configure dual boot with rEFInd.

This would all be fine, but I additionally forgot the password to the Ubuntu user. This means that I am unable to repair the bootloader, which would allow me to load a new OS onto the computer, along with a known admin password.

I'm wondering if my GPU also has issue as only the MiniDisplay Ports work, and not the DVI, which could lead to issues displaying the bootloader screen upon startup.

I've tried NVRAM reset (chimes ones, black screen). I've tried holding Option when I boot (still black screen). I've reseated the RAM. It's just a strange problem. I figured I could just load a new OS on, but the only thing I get is the Ubuntu splash screen and then Ubuntu's desktop (I set it to automatically log into the user, but I have no sudo access).

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Load a Mac OS onto another drive using a Mac and then put it into one of the bays and boot from it. MacOS:X 10.5.6 through MacOS:X 10.11.6*

Bu yanıt yardımcı oldu mu?

Puan 2

5 Yorum:

I've tried a USB media installer.

I'll try to load macOS onto a hard drive, pull out the Ubuntu partition, and see if that forces it to boot from the macOS drive. Then report back. Thanks you!


BTW I use an OWC Accelsior S

2.5-inch SATA 6G SSD to PCIe Expansion Card to double my speed from the hard drives bay 3.0G to the PCI slots 6.0G plus the added speed of an SSD. Plus it's cheap at $27.00, even with an added 1TB drive it's only $85.00 ( a 2TB at $143.


Way ahead of you. I have three of them in a RAID 0 config backing up to a HDD hourly. I still have not had a chance to load Mac OS X on to a drive, it's on my list. I want to save this machine and give it a second life! It's a lot of material to go into the trash otherwise.


Keep an eye out on this Q& A. I'm taking one of my Pros to Monterey:

OpenCore Legacy Patcher vs Dos Dudes Patchers Also going to a faster wi-Fi & BlueTooth using this adapter and a BCM94360CD


Ultimately, I have taken a macOS (High Sierra) disk from an alternate Mac, attached it to one of the bays, and have been able to load into the OS. Still no bootloader/the option key does not work.

I’ve also swapped out the clock battery, swapped out a GPU, taken out a couple sticks of RAM that might be bad, successfully reset the NVRAM/PRAM, and still no dice.


Yorum Ekle

Yanıtını ekle

Randall B sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 2

Son 30 gün: 3

Her zaman: 38