Ana içeriğe geç

Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

551 Soru Tümünü görüntüle

MacBook iGPU failing after battery replacement

I just recently replaced the battery on my old macbook and it’s working great, lasts for hours, snappy fast. The only problem is I somehow seem to have broken the iGPU in some way. I’m really not sure how this is possible since I’ve never heard of an iGPU failing but it seems to be the case. The installation went smoothly so I’d be a little surprised if I broke anything in the computer - especially the CPU/iGPU because I went nowhere near there.

It happens about 80% of the time on startup, the whole computer just freezes - mouse, keyboard, even the screen brightness and backlight brightness buttons stop working. The caps lock key continues to light on and off when pressed. If it doesn’t happen immediately it seems to work until shut down or enters sleep - upon waking it has a really high chance of happening again. It always happens right after turning on the computer, usually in the login screen or just after it. It’s very noticeable when it happens because all the cursors stop flashing and everything. Booting into safe mode works since the graphics kext isn’t loaded and through that I was able to get this crash log. I’ve reinstalled the operating system three times - completely wiping the drive and installing from a USB. The issue has been reproduced every time in Big Sur, High Sierra, and through OCLP Monterrey. Given that it doesn’t seem possible it’s a software issue.

Booting from a Linux USB also works and I’m able to run CPU and GPU benchmarks like normal there. The only thing I can think of is that the new battery is faulty in some way and not delivering peak voltage to the GPU which is causing it to fail but that just seems sort of unlikely since a lot of this testing was done plugged into the wall and because it was able to run through a whole Metal/Vulkan Geekbench compute test without crashing.

For next steps I think I’m going to try putting the old battery back in and see if the issue goes away but it’s not exactly an easy repair to do twice so I figured I’d ask around if anyone has any ideas.

I’m thoroughly stumped.

The crash seems to be too long to post here so here’s a pastebin link:

Pastebin

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

1 Yorum:

As mentioned in a below answer thread I tried booting macos from an external USB SSD and the issue was still reproducible so it's not an internal SSD failure.

tarafından

Yorum Ekle

1 Cevap

Filtre ölçütü:

The iGPU is just the Intel graphics engine within the CPU unit.

So the fact you are able to get the system to work within Linux from an external drive removes the CPU/iGPU logic it’s self, it also likely removes the possibility of a bad RAM chip as the iGPU uses it for buffering. So at this point I think you need to create a USB thumb drive that is bootable with a fresh install of macOS release you are using. Let’s see it that too fails

Bu yanıt yardımcı oldu mu?

Puan 0

11 Yorum:

I’ve done that already-I even tried multiple versions of macOS, Big Sur, High Sierra, and (using OCLP) Monterrey. Each time I completely erased the internal storage including the EFI partition and reset the PRAM and SMC, but the issue persisted upon clean install.

tarafından

@tman1677 - You jumped to far! I wanted you to build an external bootable drive! Reloading the internal doesn’t help in diagnosing the issue if the drive has a problem.

Think it this way why does Linux work and MacOS not? What’s different? We know the chip is not the problem as it would have failed under either OS. So is the issue drive or is the displays resolution the issue as the OSs don’t run at the same frequency.

tarafından

I can now confirm that the issue is still reproducible when the OS is booted from an external USB SSD. I did a fresh install onto the external drive and wiped the internal drive and was still able to consistently reproduce it so I think a drive failure is out.

Interestingly enough, this time when the machine is frozen it still responds to screen brightness keys so maybe it's a slightly different failure than before? I'm gonna try to pull a crash report.

It is extremely interesting that it worked on a Linux bootable USB, I'm thinking maybe due to driver differences they're using the GPU at different frequencies or different APIs within it, do you think that's a possibility? I'm curious what you mean by the displays resolution being a potential issue.

tarafından

Can't get the same crash report to reappear on the external drive but the issue is very much there. I got a shutdown stall error report if that's useful to you, although when I loaded it in spindump it didn't show anything obvious to me:

https://pastebin.com/raw/7dqJGQqf

tarafından

@tman1677 - What happens when connecting an external display via the TB port? Do you see a clean image there?

tarafından

6 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Tristan Kreindler sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 1

Son 30 gün: 2

Her zaman: 52